View Full Version : G531GT Armoury Crate Stopped reading temps. Unable to Reinstall from Store. - solved

07-29-2020, 10:05 AM
So the App is gone from the windows app store. I no longer have any method of controlling my fans, or lights.

A day ago, I noticed my keyboard wasn't lighting according to cpu temperature. So I went and checked and all my temperature details were marked as 0 or not there. I assumed I might have broken a service as I was heavily tweaking my windows 10 install to remove as much privacy violating microsoft crap as I could. Decided I should Uninstall the APP and reinstall it.

Well the APP isnt on the windows store anymore, and the tool to reinstall doesnt seem to redownload the app. So im locked at default fan speeds, with a red backlight that I can only brighten or dim.

Looking for solutions, I have an Asus Rog G531GT. Basically I want an offline installer for the Armoury Crate App,one that doesn't rely on the windows 10 store since it seems to be refusing to reinstall. Why Its so heavily tied into the windows store I have no idea. However it makes me angry that this is the way it is, and that it updated without my knowledge and Broke when it did so.

I have been trying to use the ArmouryCrateInstallTool.exe but it just loads up the ROGLSLoaderBar and says updating for a while then closes and if I run it again asks me if I want to install the pre-requisites.

So I got the App Working and services seem to be running.

Issue is still here though, Armoury Crate Cant see my CPU Temp, Voltage Or Fan Speeds.

Edit 2:
Got It working, Had to reinstall intel xtreme tuning utility.

Leo Lim
08-28-2020, 01:54 PM
Is this?

However, it does not mention i5-9300H or i7-9750H in the note.

09-11-2020, 07:59 PM
Thank you!!! This fixed all the issues I was having with Armoury! My CPU is not listed either, but it worked. Thankyou for posting this!

Leo Lim
09-17-2020, 08:22 AM
After downloading of software, it's work! Thanks!