PDA

View Full Version : Asus Strix Flare Backward Media Button Light Not Working



Wollowon
09-07-2020, 01:02 PM
Hello , as title , backward media button light not working , button itself working , It was working before , if there isn't solution I will send to service for change.

Asus Armoury 2 Software Version: 3.0.44 - Up To Date.
Asus Strix Flare Firmware Version: 0.00.38 - Up To Date.

MasterC@ROG
09-29-2020, 12:04 PM
Have you tried updating to Armoury Crate? Armoury II is not maintained anymore.

Wollowon
09-30-2020, 10:18 AM
Have you tried updating to Armoury Crate? Armoury II is not maintained anymore.

No I didn't , I send to service they gave me new Strix Flare , updating software can't fix this problem because service told me problem is led , somehow stopped working.

MasterC@ROG
10-07-2020, 03:42 AM
I see, so the new keyboard is okay?

Bloperman
10-14-2020, 06:10 PM
I see, so the new keyboard is okay?

I have the same problem.
It is something with the firmware.
Next track media button isn´t working.
Please fix it.
Gonna rma it.

MasterC@ROG
10-15-2020, 01:45 AM
Solution sent via PM


I have the same problem.
It is something with the firmware.
Next track media button isn´t working.
Please fix it.
Gonna rma it.

antony209494
01-01-2021, 04:07 PM
If one of the media buttons doesn't work at all then maybe it's a firmware issue and can be fixed. If it's a LED dying or dimming then it needs RMA cause the LEDs on the media buttons are really crappy quality and die after some months of use. Had to RMA 2 flares because of it and I totally expect the third one to die too at some point. Really bad look for such a pricey keyboard.

cekeu
09-12-2021, 05:31 PM
If one of the media buttons doesn't work at all then maybe it's a firmware issue and can be fixed. If it's a LED dying or dimming then it needs RMA cause the LEDs on the media buttons are really crappy quality and die after some months of use. Had to RMA 2 flares because of it and I totally expect the third one to die too at some point. Really bad look for such a pricey keyboard.

I have this led failure too, The Play / Pause led then the Previous Track led. They will die one after the other.
Fortunately, the typing keys seem to be holding on.

Englishman.Xperia
03-09-2022, 02:04 AM
Hi,
I got a RoG Strix Flare Keyboard and today I noticed that the "STOP" multimedia button LED is not working.

The white LED that should be lit is not working. I tried connecting the keyboard to other computers but still the same.

The Button itself works and stops the video but the light is off. All other multimedia buttons are ok.

92401


Thank You for your help

Englishman.Xperia
03-09-2022, 02:30 AM
I have now the STOP multimedia button with the LED not working.... :(

Sten.
03-20-2022, 01:35 PM
Same here, my stop key LED also died after having this keyboard for about a year, I never use those multimedia key.

MasterC@ROG
03-20-2022, 03:16 PM
Did the FW provided work for you in the end?


I have now the STOP multimedia button with the LED not working.... :(

MasterC@ROG
03-20-2022, 03:17 PM
Try holding down FN+ESC for around 15 seconds until all the LEDs start flashing, this will do a factory reset. Test on a different system as well.



Same here, my stop key LED also died after having this keyboard for about a year, I never use those multimedia key.