PDA

View Full Version : G73JW-3DE brand new laptop with problems!



Heim
01-06-2011, 10:47 PM
Hi all and thanks for reading this post.

I have just recently purchased a G73JW-3DE laptop and had it delivered today. Unfortunately when I went to turn the machine on the screen did not come on with it. The rest of the lights came on and the unit appeared to have booted up (even the blue strip of light on the screen came on! ;D ).

So after frantically searching around the machine for some kind of button or switch I might've missed, I decided to try an external monitor. Now this worked, I was able to use windows and use the machine fine. So there doesn't appear to be anything wrong with the graphics card.

This leaves me to conclude that there is a loose connection to the screen or the screen itself is dead. Checking with the retailer, these units are all tested before shipping.. so this screen must've worked at some time!. So I'm hoping on a loose connection.

Has anyone here been inside the machine tinkering that could give me some direction on how to check all the connections? I have plenty of experience with desktop machines, but quite limited with laptops. Some kinda guide as to what I'm looking for or a picture would be handy.

Thanks for any input.

Chastity@ASUS
01-06-2011, 11:22 PM
Google for the BTOTech Disassembly Guide for G73JH (same case) It goes over the screen connector too.

Heim
01-06-2011, 11:49 PM
Hmmm I come across this one http://www.youtube.com/watch?v=Tp90M_N6dzs . Is this the guide you refer to? It doesn't seem to go over the video connectors, but then it does get me inside the beast and access to the video card! :). I'll let you know how I get on. Thank you very much.

MustangDude
01-07-2011, 05:55 PM
Have you tried the special function keys? There are two function keys that could disable the screen. One is just plain turn screen on and off. Second one is (use Monitor/Monitor+HDMI out/Just HDMI out). I believe they are F7 and F8 but I am not sure.