View Full Version : Armoury Crate Lost all my devices (again!)

10-22-2020, 10:47 PM
Hi All,

In the hopes that ASUS is listening today I updated the BIOS on my Crosshair VIII Hero. No drama from that. Updated, cleared CMOS and put all my custom timings and stuff back in. No big deal. Back in windows and all is good.

Except it is not. Armoury Crate has again s*** the bed (again!!!).

First I noticed Aura was no longer working so I fired up Armoury Crate to discover the only thing it could still see was my RAM (which is gone now too as I tried to uninstall/reinstall this utter mess). My Ruyjin, XG279Q, MB and LED strips (in the case) where all gone.

So I went to devices and it can see the MB and Ryujin but the pages for controlling them are both blank.

I tried to uninstall the whole thing properly (which has wasted most of my day as it sprays garbage all over the system) and then reinstall it which has improved things. It now at least searches for devices in the AURA tab. Doesn't find any but at least it is looking.

Anyway I thought I would share my experience in case anyone has any ideas before I blank the drive and reinstall windows.

Come on ASUS, your hardware is great but this software is without doubt some of the worst garbage I have come across. Indeed I even contemplated just dumping the ASUS parts on Ebay and going to Gigabyte or something.

11-01-2020, 09:22 AM
Having similar issues that started this week (after BIOS update). Crosshair Hero VIII, Ryujin 240, ARGB strip, fans, etc. I did a quick check for updates every 2-3 days since scenario profiles were added to mine because the settings won't change back to a default after quitting a game. (also looking for more control for fan speeds, etc. in the profile setup, more like asus laptops) Anyway, haven't been on since the update, but when I started up, I got pushed to a scenario for a game at windows start, I check armoury crate and the "aura sync" and device pages were empty, no devices showing. When I tried to switch tabs from synced devices to lighting effects, it repeatedly crashed the app. Tried this several times, restarted, tried again. Still crashed.....

So after numerous failed attempts to change my lighting manually, I uninstalled Armoury Crate. IF YOU ARE CONSIDERING DOING THIS, WAIT! After uninstalling I have not been able to re-install. Not sure what happened, I've used the windows uninstaller, the Asus uninstaller from the same download page as the installer. It runs until moments from completion and fails. I clicked download on the MBs page and it goes to a windows store beta file that has been removed/locked. (FYI, I have DLed the installer about ten times to make sure I have no issues affecting the download and got the same issue with each new copy, clean installed each time)

In the end I located the package installer for just armoury crate that the main installer dropped in a temp folder. It consistently hits around 95% then fails with a "0x80073D05" error (it's a microsoft appx installer file and the code means they don't have a a clue what happened). So, not sure if there is an issue with the current installer and re-installing, or if something happened to my system during the uninstall.....

11-01-2020, 12:12 PM
After countless reinstalls, restore point and backup restores I finally narrowed down the issue of Armoury Crate suddenly not recognizing anything (motherboard, RAM, addressable LED strips).

The "AURA lighting effect add-on" and "AURA lighting effect add-on x64" did get recently updated from 0.0.12 to 0.0.13 and the software just doesn't work with the .13 version anymore, even when using the uninstall tool and reinstalling. I will try to disable Asus Update to keep the working version.

EDIT: even after disabling every possible Asus update service it still updates and breaks.

It could be the same issue.

11-02-2020, 07:55 PM
Thanks for your email.

Remove Armoury Crate, Aura Sync and all components within Windows safe mode. Then clean the system using CCleaner or System Ninja. This ensures that the registry is clean and all parts of Asus Aura are completely removed.

After this restart the computer and only install the latest version of Asus Sync from the below website. Please note that you install this by right clicking on the setup file and then executing with administrator rights.


I tested this reply from asus support and it works.
the link is a rollback to
think there is something wrong with the new update indeed.