View Full Version : g751j OS won't reload

10-25-2020, 02:02 PM

Hoping I can get some direction here. I have an ASUS ROG g751j laptop. Trouble initially started with windows locking up, BSODing, and finally got to the point where it was unusable. Booting into safemode however remedied the situation, so I attempted to do a repair from the recovery partition and here's where things began going down hill. That process failed and eventually got to the point where now I couldn't even access the recovery. Great, hosed my OS... i was using this for work at the time and didn't have time to fuss so purchased a 2in1 and set this on the shelf. Here we are a year later and finally ordered a recovery USB through ASUS's official channels to try and get this beast up and running. I followed the steps to disable security etc but it didn't seem to be loading the drive. Furthest I've gotten is selecting the boot media, the windows splash logo pops up and that's it. Nothing... the battery is shot so fearing that was causing issues I've removed it, still no joy. I've also seen weird things were after turning it on occasionally the screen will stay blank, or it will reboot, also keep in mind when I get to and hung up on that windows logo cntrl+alt+delete doesn't work so it feels like it's freezing. Threw the HD on a USB adapter to ensure I could access the data left on it and that the HD was functional, sure enough, so managed to back up the few things that weren't already in the cloud. I've also tried playing musical ram and still getting hung up on that windows logo while trying to load the recovery. Any ideas? I have a couple brand new sticks of ram showing up today... I'll report back if that resolves the issue.

10-25-2020, 06:22 PM

Ok, so new strip of ram isn't helping. Only thing left i can imagine is the mobo? Just curious since this originally started as purely an OS related failure and it still turns on, I can access the bios fine and it doesn't lock up or anything if left in there but still unable to load the os.