PDA

View Full Version : ROG 7.1 Centurion (can't be recognized)



Markz
12-20-2020, 03:27 PM
What to do i had to re-installed Win10, but it still doesn't recognize Centurion audio station ?
I remember that i updated to latest AMD graphics driver beta version and after reboot lights went out from audio station so i installed newest chipset drivers amd_chipset_software_2.10.13.408, but it did not help and windows doesn't recognize it as hardware except from 2 usb ports one is i guess you could say motherboard bios usb slot and one is front panel usb 2.0 slot so my guess is that those are 2.0 usb slots both and others are either usb 3.1 or 3.2 slots.

I've tried removing every usb driver so windows re-installs those which did not help and i've tried updating each usb driver which did not help and i had a thought that it might be broken audio station which doesn't make any sense, because when i plug it in headset lights light up for 2 seconds so power goes through and it does it each time i do it. I checked bios and it doesn't have any usb suspend mode on or anything like that.

I don't have those windows updates installed that needs to be removed, but i have updated firmware from audio station to Version MCU 1.8/DSP 2.0 Beta Version
and i had Version 1.1.19 Beta software installed.

So how could i force usb to recognize audio station again?
No firmware update doesn't work as i can't point to that usb port from your flash programs just says that it can't be found.

Here are couple pictures i took with phone might look messy shots as it's curved monitor :

87247
87248
87249
87250

Did a shutdown and took power cables off and when i powered back up it's still the same. Also tried that new driver, but as you can guess it didn't work either.
87258
87260

Markz
12-20-2020, 04:54 PM
I'll test disconnecting power supply and connecting it back if that makes any difference. Edit: Audio station was out after 1 year i threw it in garbage and ordered new headset. I know i know i should've RMA it, but i can't wait months to get it or replacement back. Thanks ROG team Centurion had beautiful 7.1 sounds after fiddling with EQ settings and hopefully you can make better 7.1 in near future and please for the love of god try to make those a bit cheaper compared to competition emulators. You don't really need such audio station anymore as competition runs sound cards with EQ softwares/freewares. Make those awesome 7.1 headsets if corded with at least 2m cord plus your brilliant sound cards (with speaker attachment like in audio station), but leave those fancy buttons out you can really do all that from EQ side from your Windows 10 software.