PDA

View Full Version : Weird GTX 570 DCII



dasfast
04-01-2012, 11:51 AM
I bought a GTX 570 DCII in December 2011. It was artifacting, black screening, bsod, you name it. I got an RMA issued in late January, and in about 2 weeks I got a different card returned to me. It did not seem to have any of the problems the previous card did. I installed Battlefield 3, which was I got the GTX 570 in the first place. After about 4 hours of play, I started noticing some artifacting. I installed GPU Tweak and monitored the temps and they would get up to 80c. Seems a little hot for me. I tried upping the voltage from 1.038 to 1.075 and that solved the artifacting, but the card got hotter. I also notice a squealing noise coming from the video card when it is under load. I tried to overclock the card just for fun and I got the core to 842 mem 3900 vcore 1.100. That seems like a lot of vcore increase for such a modest overclock. Especially since on the box says up to 50% faster with Voltage Tweak. Should I try to RMA this card?

System Specs
Intel i7-2600K 4.5ghz 1.34v
Gigabyte GA-Z68XP-UD3P
4x4Gb G.Skill RipjawsX
ASUS GTX 570 DCII
WD Caviar Black 1TB
Seagate 2Tb
Crucial M4 64Gb (Raid Cached)
LG UH10LS20 BluRay
Pioneer BDR-206 BuRay Burner
Corsair Carbide 400R Case
Corsair H100 Cpu Cooler
Antec TruePower New 750 W PSU

essanbee
04-02-2012, 02:22 AM
I bought a GTX 570 DCII in December 2011. It was artifacting, black screening, bsod, you name it. I got an RMA issued in late January, and in about 2 weeks I got a different card returned to me. It did not seem to have any of the problems the previous card did. I installed Battlefield 3, which was I got the GTX 570 in the first place. After about 4 hours of play, I started noticing some artifacting. I installed GPU Tweak and monitored the temps and they would get up to 80c. Seems a little hot for me. I tried upping the voltage from 1.038 to 1.075 and that solved the artifacting, but the card got hotter. I also notice a squealing noise coming from the video card when it is under load. I tried to overclock the card just for fun and I got the core to 842 mem 3900 vcore 1.100. That seems like a lot of vcore increase for such a modest overclock. Especially since on the box says up to 50% faster with Voltage Tweak. Should I try to RMA this card?

System Specs
Intel i7-2600K 4.5ghz 1.34v
Gigabyte GA-Z68XP-UD3P
4x4Gb G.Skill RipjawsX
ASUS GTX 570 DCII
WD Caviar Black 1TB
Seagate 2Tb
Crucial M4 64Gb (Raid Cached)
LG UH10LS20 BluRay
Pioneer BDR-206 BuRay Burner
Corsair Carbide 400R Case
Corsair H100 Cpu Cooler
Antec TruePower New 750 W PSU

I have the same GPU as you do and I set mine up to the same OC and never got above 59C with the fans on default auto setting. Room temp 70F. As you have a low OCer, high temps, and a funky noise I would recommend RMA if possible. My box does not say 50% faster, but it does say 20% cooler...