View Full Version : Device Tab Won't Load

01-28-2021, 11:52 PM

I've been using the X570 E for about 2 weeks now and having some issues in Armory Crate (V3.3.7.0)
All the tabs seem to work except for the first one, ie the Device tab.

I click on it and it shows the motherboard
I click on that, it kind of loads for a split second then flashes.
Then it goes into a red loading circle indefinitely.

In Aura Sync is shows my board ^ argb strip and they both work fine and without issue.

But cannot get the device tab to load have tried uninstall etc etc but it will not show.

Any idea's

01-29-2021, 12:12 PM
i have the exact same issue

02-05-2021, 01:07 AM
Latest update has fixed it, as in I can now go in and select my mother board on the devices tab and finally turn off the rgb for when it shuts down after 2 months.

Even at that just loading the motherboard in the tab looks terrible, flickering and very slow to load. Looks like it could crash any minute.

Will make sure if I'm upgrading going ahead to avoid any further asus products that rely on this terrible software. For the cost of the items you'd expect at least some high level functioning software.
But again that's most companies these days.. get your money and push out half ready crap and leave the buyers to sit and wait for whenever they might bother to fix it.