View Full Version : Armoury Crate not Detecting Motherboard

01-29-2021, 07:00 PM
Hopefully, somebody can help me with this because I have not been able to find a fix for it. I have a ROG Strix Z390-E Gaming motherboard, but Armoury Crate won't detect it, so I can't adjust the lighting effects. However, it does detect my RAM.
Anyway, I reset my computer last night, and that's when the problem began. Before I reset it, I had the old Asus Aura app and Armoury Crate installed, and Armoury Crate detected my motherboard at the time, but after the reset, it just won't. I don't have the old Asus Aura app installed anymore, but I can't imagine it needed that to detect it. Either way, I can't find the download link to it anymore since they combined the two apps.
So far I have tried restarting my computer multiple times (of course), checking to make sure lighting is enabled in the BIOS (it is), uninstalling and reinstalling Armoury Crate and all of its related components both through the Windows uninstaller and IObit, making sure all of my drivers are up to date, and updating my BIOS to the latest version. Nothing has worked, and I have no idea how to make the software recognize my motherboard. I'd certainly appreciate any help, but it looks like many other people have had this issue too and never found a fix for it.

01-30-2021, 06:43 PM

02-14-2021, 01:02 PM
i have the exact same problem, and i tried nearly anything and nothing helped. even two complete OS reinstalls did not fix the problem, that my mainboard is not found by armoury crate and so i could not adress any of the plugged in rgb strips over the board. it's kind of annoying, because the only thing that lights up and is adressable is the ram and the gpu leds.

what i did until now:
- updated to the newest bios
- cmos reset with battery and jumper
- unplugged complete system over night
- swapped hardware (ram and gpu)
- tried if maybe the rgb hardware is broken it works in another system
- os reinstall
- in os used the deinstall and clean tools and setup tools
- used the clean tools and reinstalled os

the only thing i did not try is to deactivate the armoury crate install function in bios and reinstall the os after that, because i am tired to reinstall my whole system everytime...

The asus-support is already on that. i have a feeling that armoury crate somehow managed to rip my board hardware.
anyone got an idea what could fix this?

02-15-2021, 12:02 PM
hi.im tired of this asus aura and armoury crate things, its a shame that asus hardware are good but when it come to software
is not good.it was finaly good when i managed to run aura and corsair together with no issues ,.then i had my asus 3080 and for that
aura was not supported.so i had to dl armoury crate which is broke my mb rgb and not recognized + my ek water coolin rgb which is connected to mb.
why they didnt just add 3080 to aura ???,that would have been perfect and no issues.now we got 2 software from asus that dosnt work probabley.
one work with mb and other light but no 3080 gc, other work wit 3080 gc but mb broken.


,and when ur armoury crate can be sorted it then we dl that as well.
ive tried everytjing to make them work but nothing changed.at the moment i just using aura to sync mb.fans.ram.ek rgb.but 3080 gc is not working.

hopefuly asus get this sorted .

maximous xi hero mb
ek watercooling rgb
corsair ram and fan rgb
asus 3080 tuf