View Full Version : Asus ROG Delta Headphones MIC problem

02-12-2021, 07:06 PM
Recently, when I use the voice chat in any game after every first boot my pc/laptop, headphone mic is really low. Repluging it fixes the problem, doesn`t matter if I use usb C or the adapter extension (normal usb3.0/2.0). Is this problem fixable or I have to unplug the connector and plug it every time I boot my pc ? I have all new drivers available installed, newest version of windows, bios, everything possible. Overal the headphones are 10/10, except this little problem that I have :o

2) I installed sonic studio and now my sound effects are not working in armoury crate. I reinstalled drivers, programs, rebooted my system couple times, changed the usb cable (usb c), nothing works.... Now I can`t change Sound Optimization stuff - nothing is working. virtual surround, equalizer, bass boost etc. Please someone tell me how can I fix this ? I even reinstalled the firmware of the headset-same....

02-16-2021, 08:10 PM

03-31-2021, 08:59 AM
no solution till today

04-23-2021, 06:12 AM
Hello Ivaylo,
What kind of pc/laptop are you using? which model is it?
Does this issue happen on other pc/laptop?
and does this issue happen in video call? or just in specific game?
Thank you.

04-23-2021, 06:38 AM
I tought i was the only one having this problem...
Like since a month or 2 / 3 ago my mic is always low when i enter a discord server, people have to crack up there volume to hear me better.
After i replug my usb my mic is working perfectly again.

Now since this week its starting to become worser and worser... after i replug i can use my mic for +/- 5 minutes before its getting shut down and won't work anymore untill i replug the usb cable (i even change it on different ports to see if the problem stays) and it is..

I've been very gently and taking care of my headset the past 2 years but yesterday i've almost threw my headset out because of this frustrating problem.
So please asus fix the drivers!

04-27-2021, 06:12 AM
Hello Asuslogie,
Does the issue happen on another headset? or another PC?
And only using Discord having such issue? or any video call?
Thank you.

04-28-2021, 12:56 PM
Same problem here, except there is absolutly no sound from the mic anywhere.

The version of microphone observed in the App Armoury Crate is 00000 ? i think the micro-software dedicated to the microphone is ****ed up.

Need an hotfix right now !

05-01-2021, 12:03 AM
Hello, We are working on this issue and get back to all you. Thank you

05-04-2021, 06:49 PM
Hello everyone, we just release the new ROG Delta firmware today 5/4/2021.
Please see if you all update it and see if it fixes your issues. Thanks

05-04-2021, 11:14 PM
Mic is still not working after Firmware update 0045. I have already done a complete reinstall of Armory Crate, Realtek drivers, Sonic Radar 3 and Sonic Studio 3.

05-05-2021, 12:37 PM
it doesn't work with Rog Delta S..

05-05-2021, 09:43 PM
Mic is still not working after Firmware update 0045. I have already done a complete reinstall of Armory Crate, Realtek drivers, Sonic Radar 3 and Sonic Studio 3.
After firmware update and still have an issue ,unplug and plug the ROG Delta; test on another USB port, test on another computer to verify that it is Delta having the issue
If microphone still doesn't work on another system, the microphone is malfunctioning. RMA the Delta if nothing works!

05-13-2021, 07:54 AM
Ok.. so for now my mic seems to work 60% of the time but now i have no idea what the cause is that destroyed my headset's sound optimization but i can't edit/use my profiles to have better sounds in armoury crate they all sound the same no matter what i choose...