PDA

View Full Version : ROG XG32VC Monitor - KVM Issue



celticguy75
03-18-2021, 02:50 PM
I recently upgraded my monitor to a XG32VC which features a KVM function.

I have a Logitech G910 keyboard & a Logitech G502 mouse which are currently plugged into the monitors two USB 3.1 downstream ports. The upstream port is then plugged into my PC's 3.1 port which is using a ROG X99 Strix Gaming Motherboard.

I also have a work laptop (which is encrypted and secure so any software solution is out of the question) which is connected to the monitor via a USB-C cable.

I have noticed that repeatedly, the keyboard stops functioning when the monitor is set to use USB mode. The RGB effects still work, and the mouse will work, but the keyboard is not working until I either unplug the USB cord, switch function to USB-C and then back to USB 3.1 or turn the monitor off & on again, thereby "cycling" the inputs. I've tried different cables, different ports on the monitor and PC. At first I thought it was a standby mode or something similar, but the keybboard can stop working at any time. The USB Hub seeting on the monitor is set to On During Standby but this is the only function within the monitor settings that seems to have any relevance.

The issue did not occur when I used a dedicated KVM switch. The USB-C connection works fine and does not seem to have the same "dead keyboard" effect.


Any suggestions or advice would be hugely appreciated as I would prefer not to have to use another physical KVM when the monitor has the function built in.