PDA

View Full Version : G74sx Skyrim performance



Basilo
04-04-2012, 12:48 AM
So, I have a three month old G74 i ordered through powernotebooks.com with all the bells and whistles, like 16 gigs of ram and the i7-2860M CPU, but I think the graphics card may be defective. Basically, with skyrim on high settings, i get an average of around 20 fps, even though when I press the default settings button, it goes to ultra. Is this an average performance, or is something messed up with my laptop? I do have all the drivers updated, and have taken to using the beta drivers, and my WEI gives me a 7.2, so i feel i should be getting better performance. Thnx! Oh, and ive been monitoring my CPU, memory and graphics card, and only the graphics card maxes out when playing games, but it almost always immediately peaks.

zsld0423
04-04-2012, 04:11 AM
Have you tried using the Throttlestop program? There's a known issue that when the CPU and GPU start to max, it throttles the computer :( Or something along those lines. Here's the thread detailing about the issue and what to do. Personally, I'm running Skyrim just fine on my G74 on all ultra, no lag or anything

http://rog.asus.com/forum/showthread.php?2329-ATTENTION-G73-53SW-Owners-CPU-Throttling-to-798mhz-and-how-to-fix-it&country=&status=

Basilo
04-04-2012, 02:19 PM
Honestly, I hate my G74, and my F50sf works better than this computer does in the graphics department. I will happily sell this computer to anyone who ask.

MrRuckus
04-04-2012, 05:50 PM
Im not sure how a GT220M is going to run better then a GTX560M. Have you checked that thread the previous poster replied to you with? That will most likely solve your problem by running ThrottleStop.

Basilo
04-04-2012, 07:25 PM
It doesn't make any sense to me either, all I know is that I am playing games at the exact same settings on this computer as i was on my f50, and getting almost the exact same framerate, but on this one the graphics card is the bottleneck, and the CPU was the bottleneck on my old one. Ok, I got throttle stop working and fraps says im getting 40 fps, but the screen looks like 20-25 fps, and i can clearly see lag when walking as things near the border of the screen form a double image for a very small, yet noticeable, period.

MrRuckus
04-04-2012, 07:53 PM
It doesn't make any sense to me either, all I know is that I am playing games at the exact same settings on this computer as i was on my f50, and getting almost the exact same framerate, but on this one the graphics card is the bottleneck, and the CPU was the bottleneck on my old one. Ok, I got throttle stop working and fraps says im getting 40 fps, but the screen looks like 20-25 fps, and i can clearly see lag when walking as things near the border of the screen form a double image for a very small, yet noticeable, period.

Do you have the newest drivers from Nvidia? Almost sounds like somekind of driver issue. Or possibly a refresh rate issue?
I may try and hook it up to an external display via HDMI if you can to see if the same thing occurs.

Basilo
04-04-2012, 08:04 PM
I have the Nvidia beta drivers, but i have yet another question. What kind of framerate do you get in crysis and crysis 2, because for both on their second highest settings i am only getting about 25 fps, even when i overclocked to 917/1834/1450. Might I mention that that is about the exact same framerate i get in crysis on my old laptop on medium settings.... im very disappointed with this computer.

smellons
04-04-2012, 10:15 PM
In addition to checking the nvidia drivers, also make sure you have Skyrim at the latest version, there have been many improvements in performance. And double-check you're on High Performance Mode.

Did you uninstall any of the bloatware/ clean install?

Also, the f50 was only 1366 x 768 with a ddr2/ddr3 gpu while the G74 is 1920 x 1080 with a ddr5 gpu.

muteKi
04-05-2012, 08:56 AM
And double-check you're on High Performance Mode.

Seconding this, since nothing else seems to have an obvious effect; it's also the main reason I ever have lag/framedrop issues with games -- though I should point out the caveat that I haven't tried playing Skyrim on this unit.

Tech_Rat
04-05-2012, 09:26 AM
I had no problem with lag or FPS issues while playing skyrim on the G74SX-BBK8. Had High res texture packs on everything, all settings maxed out. I am using the 296.10 (http://www.geforce.com/drivers/results/42588) drivers. Check the throttle stop if you haven't. Make sure the power mode[the battery thing in the bottom right corner on your task bar] is set to high performance, and not battery saver. I don't normally use the beta drivers. Make sure Steam and Skyrim are both updated. I know skyrim has an official parch for the 4GB+ RAM users.

Basilo
04-06-2012, 03:31 PM
Ok, I have done everything listed above, and none of it helped. Also, the bbkX models have a lower resolution screen than the normal g74s. Basically, asus is behind in the gaming laptop field. Until they make an SLI model, they are going to be last.

MrRuckus
04-06-2012, 09:01 PM
I would guess something is wrong. Others do not have this problem.

http://www.youtube.com/watch?v=dqkqxdYsYAo

newborn
05-08-2012, 08:35 AM
I have a G74sx as well. Brand new, not even 1 month old. I can pretty run most game around 60 fps on high settings, however in Skyrim I have around 20 or lower in Ultra details. Only 50 fps in medium graphic.

Have seen a lot people playing Skyrim flawless on ultra with this laptop.

Anyone figured out what to do here?

fuzon1337
05-08-2012, 08:41 AM
I have a G74sx as well. Brand new, not even 1 month old. I can pretty run most game around 60 fps on high settings, however in Skyrim I have around 20 or lower in Ultra details. Only 50 fps in medium graphic.

Have seen a lot people playing Skyrim flawless on ultra with this laptop.

Anyone figured out what to do here?

It could be because of the throttling issue that have not been fixed yet. But there is a temporarily fix about how stop the throttling:
http://rog.asus.com/forum/showthread.php?2329-ATTENTION-G73-53SW-Owners-CPU-Throttling-to-798mhz-and-how-to-fix-it&country=&status=

Have you installed any new patch lately for that game ?

newborn
05-08-2012, 09:08 AM
It could be because of the throttling issue that have not been fixed yet. But there is a temporarily fix about how stop the throttling:
http://rog.asus.com/forum/showthread.php?2329-ATTENTION-G73-53SW-Owners-CPU-Throttling-to-798mhz-and-how-to-fix-it&country=&status=

Have you installed any new patch lately for that game ?

Hi, thanks for your reply.

I bought the game in steam so I guess it's getting updated automaticly. I will give your link a try.

fuzon1337
05-08-2012, 09:13 AM
Hmm.... which nVidia driver are you on now ?

newborn
05-08-2012, 09:42 AM
It could be because of the throttling issue that have not been fixed yet. But there is a temporarily fix about how stop the throttling:
http://rog.asus.com/forum/showthread.php?2329-ATTENTION-G73-53SW-Owners-CPU-Throttling-to-798mhz-and-how-to-fix-it&country=&status=

Have you installed any new patch lately for that game ?

Just want to inform that my skyrim runs much better now, it runs 40FPS at ultra and sometimes drop down to 25 fps. Much better than what I used to have.

I'm using the latest driver for the lap: Nvidia 296.10

Thank you for your help.

Spook50
01-09-2013, 07:52 AM
Seems the OP was having the same issues I am, though none of the fixes have seemed to help me. Enabling and disabling Vsync made no difference, unparking all cores of my i7 and running Throttlestop made no difference, Turning off every one of the mods I have installed made no difference, and even dropping all the graphic settings to low/medium all STILL keeps me in the low 20's range for FPS in Skyrim. I'm completely at a loss for ideas now, aside from completely removing the game and doing a clean install of it from square one to see if there's any improvement.

If anyone can offer any further ideas that might be causing the issue, I'm all ears. I'm really hoping that there's just some bonehead setting that I've overlooked or something I've goofed up without realizing it.

Edit: I suppose it would help if I annotated my system's specs (late night typing of an exhausted dad after getting his kid to bed):
G74Sx w/ BIOS 201 (official)
Intel 2630QM
14GB RAM
5400RPM 640gb HDD
NVidia GeForce GTX 560M w/ 3gb VRAM