View Full Version : ROG CROSSHAIR VIII FORMULA - AQC111C 5GNIC runs like garbage

04-16-2021, 08:24 AM
i saw some threads about this NIC on this board, but my problems seems different.

when it comes to straight download speeds from my NAS, i get 300 ish MB/s when i should be getting 500 MB/s, but i can live with that. internet download speeds are fine, i get the full 1Gbps up and down

my main issue is random disconnects and occasional ping spikes that don't happen on another PC in the house and don't happen when using the intel NIC. even steaming youtube videos at 720p can sometimes be a problem. the video will just free or stop loading.

i tried reinstalling windows, tried reinstalling windows on a brand new Samsung 980 Pro SSDs. doesn't help. the 5G NIC is still annoying. the 5G NIC is the main reason i bought this motherboard and without it, it may as well be a door stop.

is there are firmware update for this thing? i can't find this SKU listed on Marvell's website. i've update aquantia NICs before with firmware from their website to fix various issue. but don't see anything of the sort here. is there any other trouble shooting/updating steps i can take before i have to rip my computer apart?

specs here, if you need them: https://valid.x86.fr/jpd4j4


04-23-2021, 08:23 AM
Hi there,
Is this a new issue after certain update or modification?
Could you share the current NIC driver and firmware version on your device?
Thank you.