PDA

View Full Version : M13H w/ 10900KF: SpeedShift prevent Turbo frequencies after idle in Balanced mode



timetoy
04-19-2021, 08:37 PM
If Speedshift is enabled there is some weird and inconsistent frequency switching behavior.

The first run of Cinebench will at full speed (5.2Ghz) and will keep running at full speed until I stop the test and let the CPU run at idle. When restarting the test the CPU will only run at 4.8GHz and all the following test will be at 4.8GHz. Opening the Settings -> Power options -> Balanced -> Change plan settings -> Restore default settings for this plan Will restart the cycle (first run at full speed then the runs following a pause at 4.8Ghz)

If I disable Speedshift everything seems to work as expected, hitting the max turbo after idle no issue

There is a different behavior in Linkpack:
Speedshift ON: Here under Linkpack Extreme (AVX part hits Turbo of 5.2GHz, while non-AVX part only hit 4.8GHz)
88411

Speedshift OFF: It all run at the max allowed turbo (AVX at 5.2GHz and non-AVX at 5.3GHz)
88412

Bios 0704 (tested all Bios version, it is the same)
Also idle power consumption is around 9-15W with Speedshift OFF and 30-40W with Speedshift ON

MrAgapiGC
04-19-2021, 10:05 PM
Interesting. I can try that. I have being running with test also. But will not run the new bios. These is also present on 0605 but diferent. on balance the 10850k goes up to 4.8 and idle , when the ai mic suppression is disable will boots to even 5.2 on light load.
I am still learning. I will check these now and compare. But on 0605 on balance will not boots and drop to minimun intel specs. I will will check these since is interesing. I will keetp the 10th gen for a while

Shamino
04-20-2021, 03:50 AM
this bios should give you max performance even on balanced power plan:
https://www.dropbox.com/s/cvc0fuedoho02gt/ROG-MAXIMUS-XIII-HERO-ASUS-0015.rar?dl=0

timetoy
04-20-2021, 06:31 AM
this bios should give you max performance even on balanced power plan:
https://www.dropbox.com/s/cvc0fuedoho02gt/ROG-MAXIMUS-XIII-HERO-ASUS-0015.rar?dl=0

I tested the attached BIOS and it seemed to have fix it!
With Speedshift enabled it will rest at idle and boost under load afterwards, also Linkpack is behaving appropriatly boosting to the max turbo speed with each cycle.

Thanks for the quick response and fix! Will this be rolled into the upcoming release BIOS?

Shamino
04-20-2021, 08:20 AM
I tested the attached BIOS and it seemed to have fix it!
With Speedshift enabled it will rest at idle and boost under load afterwards, also Linkpack is behaving appropriatly boosting to the max turbo speed with each cycle.

Thanks for the quick response and fix! Will this be rolled into the upcoming release BIOS?

yes takes some tiome

blukas69
04-21-2021, 10:56 AM
MY MH13 10900K also goes to 5.2 on a cinebench with power mode on "performance"
But on "Balanced" power setting it only turbo's to 5.0 ghz, Ive been trying to figure this out also.

I like performance mode but don't want to hang at 5.2 all the time on idle. weird power modes

performance mode Cinebench R23 ~16660
balanced mode cinebench R23 ~15750

timetoy
04-28-2021, 08:03 PM
Seems fixed in the 0707 BIOS. Thanks ASUS!

MrAgapiGC
04-29-2021, 01:18 AM
Seems fixed in the 0707 BIOS. Thanks ASUS!

yes. just testing the bios also. but i did run on some things that i will check and has to do with ai noice canceling that is services is running. i will test more tomorrow