PDA

View Full Version : ROG claymore 2



Hopper64
06-19-2021, 10:47 PM
I’m having to RMA this keyboard due to weird issues with the thing’s backspace constantly engaging. It’s quite strange. It might just be this particular unit so I’m going to try another one. A firmware update was available which fixed a bunch of problems with the 4, 5, and 6 number pad keys not working. But even getting into windows is a problem. It keeps backspacing. Any one else with similar issues? I went back with my strix and the problem resolved completely.

jimeskcp
06-25-2021, 10:58 AM
I’m having to RMA this keyboard due to weird issues with the thing’s backspace constantly engaging. It’s quite strange. It might just be this particular unit so I’m going to try another one. A firmware update was available which fixed a bunch of problems with the 4, 5, and 6 number pad keys not working. But even getting into windows is a problem. It keeps backspacing. Any one else with similar issues? I went back with my strix and the problem resolved completely.

that day I received my keyboard after updated new firmware, the numpad button number 8 and Fn key was no functionable.

But yesterday suddenly all working fine... I also don't know what the problem.

Hopper64
06-26-2021, 11:19 PM
Yes. I have sent mine back for a new unit. Hopefully it's not a pattern. I kept getting that my password was invalid when booting into windows. The keyboard was active and sending characters to the PC without my input at all. It was very strange. The FW helped for the short term but it started again so I did an RMA. Hope a new unit is better.

Phillippos
07-26-2021, 09:38 AM
Hey folks,
I didn't the introduction yet, but wanted to post same as in Facebook DIY group: https://www.facebook.com/groups/ASUSPCDIY/permalink/4256905421059179/

I just wanted to update to all ROG (except headset) by gettin hands on an Claymore II . NICE KEYBOARD! The old one was a Corsair Strafe RGB.
But now I am bothered a bit, as the FN key does not have any effect on Claymore II .
All drivers installed , searched a lot for any config in WIN10 that might have an effect, only found faq from notebook issues - ATK Hotkey Package....
What is it? Seems like I am to dumb or do I have the next piece to RMA ? That would be unfortunate.
Anyone had this issue before with a desktop ROG Keyboard? As FN Key is crucial for game mode an WinKey deactivation, I cannot use the board without this functionality.
Need Support! Any suggestions?
Thank yo a lot in advance.

UPDATED:
After reboot AND connecting numpad, AC is now performing an FW-Update again. So it seems to have been an Layer 7 issue here *facepalm*.
As the message says: be sure to connect the Numpad extension AND 2.4GHz dongle... And this I didn't the first time.

UPDATED:
No success :(

UPDATED:
Hey guys,
It's even worse, and I had to switch back to the old Strafe keyboard.
As FN is not doing any action on Claymore II , I had this "multiple input" issue here-> https://rog.asus.com/forum/showthread.php...
That makes gaming not possible at all.
So sad.
89445