PDA

View Full Version : WiFi Problems with latest updates



Bekarasha
04-07-2012, 08:52 AM
Hello,

Since 2 weeks ago i start facing wifi problems on my G74sx, when i start up laptop everything loaded up, i click on wifi, 2x on my router name and then windows trying to connect, after 10 sec it give me message “was unable to connect” 1-fix problem 2-trouble shoot. When I do 1st it trying to fix but won’t help. Yesterday I got SSD for laptop, so I thought maybe I have virus, now I will install fresh copy with latest driver and internet security and problem will gone. I was happy until I done full installation, problem was still ther :(

I have ipone 4s and ipad 3 connected to same wifi and no problem and only laptop do not want to join party :( now im using lan cable and my can love to play with it and bite it a lot.

Im using Avast IS 2012, my network card Atheros, Win7 SP1 x64 with latest updates from Microsoft and I checked Asus Live Update no new staff there.

Any idea why its happening?

Thanks

dstrakele
04-07-2012, 02:08 PM
What version Atheros WiFi driver are you running?

Does a Windows System Restore back to a time before you observed this issue resolve it?

Bekarasha
04-07-2012, 03:20 PM
before reinstaletion i did 1 time restore and next day same problem comes, but like i say, full reinstalletion on new ssd did not helped me :(

BrodyBoy
04-07-2012, 05:06 PM
before reinstaletion i did 1 time restore and next day same problem comes, but like i say, full reinstalletion on new ssd did not helped me :(
But what Atheros driver are you using? It makes a difference.

dstrakele
04-07-2012, 06:29 PM
What a) Authentication Level and b) Encryption have you configured for your wireless network in Windows on your laptop? Does it match that of your iPhone and iPad?

Bekarasha
04-07-2012, 09:47 PM
well i was using my wifi like 6 month since i got laptop, than in 2 moth i got iphone 4s and connect to same router and was using it till now with out any problems, only week ago i start facing tht error messages, so i did system restore and it helped me for few hours, next morning i got error msg :(

so i got ssd and install everything and it happen...

a) no restriction
b) same wifi router with same password and no additional configurations

dstrakele
04-07-2012, 09:59 PM
I am using a) WPA2-Personal (Authntication Level) with b) AES (Encryption).

What are your settings?

Have you shut down and restarted your modem and wireless router?

Bekarasha
04-08-2012, 12:31 PM
i have same as u, WPA2-Personal and AES (Encryption) http://i.imgur.com/tcIXW.png
i did restart it, not helped, i connected my old wifi router + internet modem = same problem, may be its new wifi drivers?

dstrakele
04-08-2012, 02:07 PM
What signal strength is detected for your router by your ASUS laptop?

What version number Atheros driver are you running? If it is earlier than 9.2.1.432, you need to upgrade it. You can check the version in Device Manager by displaying the Properties of your Atheros Wireless Network Adapter.

Bekarasha
04-08-2012, 08:02 PM
i had 3/5 signal bar, but my router is 5m miter away from me.
my current ver. is 9.2.0.458 http://i.imgur.com/tb9SR.jpg when i press "Update Driver" it saw "u runing lates version"

dstrakele
04-08-2012, 09:02 PM
Yep - that may be the problem. That version has nasty DPC Latency. You won't find a later driver than you've got on Windows Update. Download the 9.2.1.470 version from the OP of this thread: http://rog.asus.com/forum/showthread.php?5224-Drivers-Apps-and-How-to-s&country=&status=

I can't remember if you need to uninstall your previous version or do anything special for installation, like install from Device Manager by choosing to select the directory where you expanded the files or just run SETUP.EXE. Maybe Brody can jump in here if there is additional info needed.

BrodyBoy
04-08-2012, 10:42 PM
Yep - that may be the problem. That version has nasty DPC Latency. You won't find a later driver than you've got on Windows Update. Download the 9.2.1.470 version from the OP of this thread: http://rog.asus.com/forum/showthread.php?5224-Drivers-Apps-and-How-to-s&country=&status=

I can't remember if you need to uninstall your previous version or do anything special for installation, like install from Device Manager by choosing to select the directory where you expanded the files or just run SETUP.EXE. Maybe Brody can jump in here if there is additional info needed.
Good call Drew.....I think it's the Atheros driver, too. That seems to be nasty & especially persistent software, so I would make every effort to completely uninstall the previous Atheros driver before installing a new one.

1. Get rid of the old Atheros driver and all its settings
2. Reboot
3. Install the new driver using the Setup executable
4. OPTIONAL: Do a repair install of the ATK Package (in Control Panel)

Bekarasha
04-09-2012, 11:25 AM
thanks, working now, 4/5 signal bar hope wont face tht problem in future!

dstrakele
04-09-2012, 01:07 PM
Glad to hear the issue is resolved. You made it really hard on yourself, however. The version of your Atheros driver was one of the first questions we asked. It was like we needed pliers to pull it out of you...

Bekarasha
04-12-2012, 05:08 PM
:'( guys! i got that problem again...

just power up laptop, went to kitchen for 15-20 min, back and i see that i have no wifi connection :(
I clicked on icon and my router was not listed, I did refresh that window box, still no router.

Did plug in lan cable and went to router properties, restarted from router interface did not helped, after few minutes I’ve got wifi connecting some how Oo.

What can be problem now? Iphone & ipad connected to same router and facing no problems…

BrodyBoy
04-12-2012, 06:14 PM
:'( guys! i got that problem again...

just power up laptop, went to kitchen for 15-20 min, back and i see that i have no wifi connection :(
I clicked on icon and my router was not listed, I did refresh that window box, still no router.

Did plug in lan cable and went to router properties, restarted from router interface did not helped, after few minutes I’ve got wifi connecting some how Oo.

What can be problem now? Iphone & ipad connected to same router and facing no problems…

Geez, that sucks. Though some owners seem happy with the Atheros WLAN card, there are just so many who have nothing but trouble with it....honestly, I'd just go online right now and order an Intel replacement card (the 6230 if you need bluetooth, or the 6300 if you don't). It's a very cheap upgrade, and you'll probably get it and have it installed faster than you get stable operation out of the OEM card.

That said, the only suggestion I have would be to try a repair install of the Atheros Driver, if it has that option, or just uninstall it and start over. (I would also suggest disabling its BT functions, if you aren't using them.)

tWiCeAsfLyOhMy
04-12-2012, 07:30 PM
Just throwing this out there but make sure ASUS Live update isn't set to automatically download and install. I've heard of some people having similar issues when downloading latest drivers, so perhaps this is the case.

Bekarasha
04-14-2012, 11:43 AM
BrodyBoy is off since i install all drivers for lan and wlan, not using BT at all. If i call asus and explain my problem is there anything they can do under "2 years warranty" ? Replacing wlan card will be difficult for me and I got no clue how to do that.

tWiCeAsfLyOhMy after I install all latest updates I did turn off it, so next day when laptop loads up live update was out.

Aysoos
04-14-2012, 12:05 PM
Try checking your DNS settings. Last time I went to a friends house, I had problem connecting, due to weird DNS settings. Changing the DNS to automatic worked for me.

BrodyBoy
04-14-2012, 04:39 PM
BrodyBoy is off since i install all drivers for lan and wlan, not using BT at all. If i call asus and explain my problem is there anything they can do under "2 years warranty" ? Replacing wlan card will be difficult for me and I got no clue how to do that.
Off? I'm not sure what you mean...?

Anyway, the WLAN card is actually a very easy, very cheap upgrade. Many owners here have done it. It's especially easy in the G74 because the card is located just inside that big back panel....no need for any complicated disassembly, etc. If you do end up getting tired of dealing with the Atheros issues and decide to upgrade, we've got illustrated directions that take you through it. It takes about 10 minutes......no technical expertise required. :)

PILGRIM
04-14-2012, 04:59 PM
@Bekarasha : How about re-seating and/or cleaning your WiFi card? Have you ever done it?..
It could have been loosened, misaligned, or have accumulated dust/particles .
Maybe the reason why you get that on and off WiFi connectivity.

BrodyBoy
04-14-2012, 07:19 PM
@Bekarasha : How about re-seating and/or cleaning your WiFi card? Have you ever done it?..
It could have been loosened, misaligned, or have accumulated dust/particles .
Maybe the reason why you get that on and off WiFi connectivity.
Good idea, but if there's a physical issue, I think it's more likely the antennae attachments. That's certainly worth checking. The card itself can't really be misaligned because of the way that particular connector is constructed, and once installed, it's not apt to get dirt in between the contacts.

But I believe there have been a couple owners who reported loose antenna attachments (and even one, if I'm not mistaken, who discovered that his new G74's antennae weren't attached at all!).

Bekarasha
04-14-2012, 08:12 PM
@PILGRIM I had HP laptop for 2 years and I was carrying it daily to college, 3 time orange juice was on keyboard, dropet ones to sand when I was in desert, and I had no problems with wifi.
This g74sx always on my computer desk, clean aria around this laptop and its only 6 month in use. What kind of dust can be in it to make such problems…


@BrodyBoy I will open laptop tomorrow and will report all I can find in it :)

dstrakele
04-14-2012, 10:20 PM
If your Atheros WiFi card is failing, you should see events pointing to that problem in the System Event Log. See this post (http://rog.asus.com/forum/showthread.php?11400-G73JH-Woes-amp-Problems&p=82001&viewfull=1#post82001) and the thread that contains it. It discusses how a failing WiFi card can result in other problems besides internet connectivity.

PILGRIM
04-15-2012, 11:29 AM
@PILGRIM I had HP laptop for 2 years and I was carrying it daily to college, 3 time orange juice was on keyboard, dropet ones to sand when I was in desert, and I had no problems with wifi.
This g74sx always on my computer desk, clean aria around this laptop and its only 6 month in use. What kind of dust can be in it to make such problems…

The point is to try covering all the bases.. You've had no luck with it being a software issue so it might be a physical one.

As to the "dust" comment, dust is always airborne. And unless the G74 stays constant in an air-sanitized area,
there's always the probability of dust getting sucked in the machine.

Bekarasha
04-16-2012, 07:49 PM
i did open back cover, and checked wifi, everything is connected and no dust on/in :)

PILGRIM
04-17-2012, 02:42 AM
i did open back cover, and checked wifi, everything is connected and no dust on/in :)

Okay.. but have you tried re-seating it (remove then reconnect)?

I've learned an odd way of cleaning WiFi card or RAM pin areas from Chinese technicians.
They use their thumb and point finger (make sure fingers are wiped dry) to clean them.
Thumb is on one edge of the pin area, point finger is directly under it, then slide both fingers
simultaneously to wipe.

Then they use (normally) a horse-hair brush to clean the inside of the pin connector.