View Full Version : G73JH-A1 HDCP error when hooked to TV HDMI

01-10-2011, 03:49 AM
I'm new to the forum and tried to do a search but have not been successful finding an answer.

I have a G73JH-A1 and can play Blueray movies on the computer but when I try to play the same movie on my LCD 1080P TV I get a HDCP error. It says that I must hook it up to an analog output (VGA). Has anyone else had this issue or have a solution.

I have flashed the video card to the Asus supported Vbios and have updated to the most current ATI Catalyst Suite (10.12)

Thanks for the help.


01-10-2011, 04:56 PM
Here are some screen shots of the error and the BD advisor


Check Item BD Ready? Info
CPU : Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz Yes
__dwItemID=1001__ : szLibCPUName = Intel(R) Core(TM) i7 CPU Q 720 @
__dwItemID=1002__ : dwLibClockRate = 1707
__dwItemID=1003__ : dwLibFamily = 6, dwLibModel=30, dwLibStepping=5
__dwItemID=1004__ : dwLibNumPhysicalProc = 8, dwLibNumCorePerPackage=8, dwLibNumLogicalPerCore=0
__dwItemID=1005__ : dwLibCorePerPackage = 8, dwLibTotalLogicals=16
__dwItemID=1006__ : szWMIName=Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz
__dwItemID=1007__ : szWMIManufacturer=GenuineIntel
__dwItemID=1008__ : dwWMIMaxClockSpeed=1600
__dwItemID=1009__ : bBatteryExist=1
__dwItemID=1010__ : szGuess=i7
CPU (Hardware acceleration) : ATI Mobility Radeon HD 5800 Series Yes
System Memory : 4096 MB Yes
Operating System : Windows 7 Yes
Operating System : Windows 7 Yes
Graphics Card : ATI Mobility Radeon HD 5800 Series Yes
__dwItemID=1301__ : Adapter Compatibility: ATI Technologies Inc.
__dwItemID=1302__ : VideoProcessor: ATI display adapter (0x68A0)
Graphics card video memory : 1024 MB
Graphics Card Driver : 8.801.0.0 Yes
__dwItemID=1501__ : 2D Driver=8.801.0.0
__dwItemID=1502__ : COPP=Yes
__dwItemID=1503__ : RGBOverlay=Yes
__dwItemID=1504__ : DEVICE=N/A
__dwItemID=1601__ : Driver 0:
__dwItemID=1602__ : [G:] Slimtype BD E DS4E1S
__dwItemID=1603__ : eHCMDrvType=0x00046fc7
__dwItemID=1604__ : CDRom=1 DVDRom=1 BDRom=1 HDDVDRom=0
Blu-ray Disc Drive : [G:] Slimtype BD E DS4E1S Yes
Disc Drive : [G:] Slimtype BD E DS4E1S Yes
Software Player : PowerDVD 9 9.0.3316.52 Yes
Video Connection Type : Digital (without HDCP) No More Info
Player Capability for Bonus View : Yes Yes
Player Capability for BD Live : Yes Yes
Hardware Dual-Video Decoding Capability for H.264 : 1080p+1080p Yes
Hardware Dual-Video Decoding Capability for MPEG-2 : 1080p+1080p Yes
Hardware Dual-Video Decoding Capability for VC-1 : 1080p+1080p Yes
Network Capability : Yes Yes
Program version :
System language : 0409 ENU English English
Time : Mon Jan 10 09:45:30 2011
Computer : Notebook

01-10-2011, 08:32 PM
I'm not sure if you know what HDCP is but it is a copy protection mechanism. The display adapter and the display must handshake and prove that the display is not going to let anyone copy the output. Any fault in the system, from the implementation in the adapter, drivers, display, even the cable if it is too long, can cause HDCP to fail.

What brand & model is your LCD? It should, but double check that it is supposed to support HDCP.
You may want to try a different cable, just in case it is causing the issue. It's not likely, but worth a shot.
What mode do you have the screen & external LCD in, clone? You might want to switch it to output to the TV only if you haven't already.

01-10-2011, 09:03 PM
If I remember right, I saw that error with the player software that came with my G73. I was unable to play Blu-Ray on two devices at the same time (e.g. the notebook's LCD and my TV).

I fixed that by purchasing PowerDVD 10.

Does it work if you use Fn-F8 to switch to HDMI-only output as mentioned by xeromist?

01-11-2011, 02:21 AM
Did you check for software updates for that version of PowerDVD?

01-12-2011, 08:05 AM
I have tried to run this on both my 1080P Sharp Aquos LCD and also on my 1080P Sony Bravia Rear Projection in both modes (Just HDMI and also with both LCD and HDMI). I have also checked for updates to the powerDVD 9 that came with the G73 and no go.

01-12-2011, 02:41 PM
As a test, grab a trial of PowerDVD 10 and see if the issue goes away. I also found this version buried in Asus' website: