PDA

View Full Version : Bios/windows login screen shows on 2nd display



RavenNL
11-23-2021, 09:00 AM
Setup:
Asus Maximus Hero X (bios 2701)
i7 8700k CPU @ stock
G.Skill F4-3600C17-8GVK 32gb
Nvidia 3080
Asus TUF 27 VG27a display (main screen) (connected via DP)
Asus ROG PG27 (connected via DP)

Issue:
I can't seem to get bios / windows loading screen on my main screen. It always display on my 2nd screen. In Windows it's fine but it switches when Windows is loaded. Is usually see windows login screen on my 2nd display for a brief second.

What i tried:
Changed display priority in bios to PEG instead of auto
Tried to play around with CSM settings in bios
cmos reset
Tried different cables
Tried different cable order in my GPU

when 2nd display (PG27) is turned off an reboot I still don't see bios on my main screen. Only a black screen UNTIL windows is loaded.
When I remove the cable from the GPU and reboot i finally get to see the bios screen on my main.

Also noticed when install windows (11) during the setup procedure that I don't get any picture on my main screen after it reboots for the first time. When I connect/turn on 2nd display I do see the windows setup assistance


I really don't understand why somethign this simple is such a pain in the ****. Why can't they make a dedicated port on the GPU that always is your main screen. I understand the advantages of displayport but this doesn't make any sense.

Nate152
11-23-2021, 06:25 PM
Hi RavenNL

Welcome to the ROG forum.

Check in the Nvidia Control Panel to see your primary display is set to 1.

Click the picture to make it bigger
90719

RavenNL
11-23-2021, 08:15 PM
Hi RavenNL

Welcome to the ROG forum.

Check in the Nvidia Control Panel to see your primary display is set to 1.

Click the picture to make it bigger
90719

Hi thanks,

In windows and NVP they both have the correct display order

90723