PDA

View Full Version : No Audio Device Detected By Windows 10 after update



Giovy007
11-23-2021, 07:56 PM
I just realized after Windows 10 Update my PC doesn't have sound anymore, I tried to see my devices and I can't find any device in the playback tab, as you can see in the picture, with AIDA64 I can see the devices but in windows, sound playback devices are not present any device, I tried to remove and reinstall, disable and reenable all audio drivers even the video ones. Please advise what might be the issue and how can I sort out this problem. Thank you all in advance!

MoKiChU
11-23-2021, 08:04 PM
Hi,

You have an ASUS ROG SS3 motherboard, so :

You need Realtek Audio Drivers (UAD - ASUS ROG SS3 MB) from the first post of this thread : [DRIVERS] Realtek Audio (MB | Intel 2xx/3xx/4xx/5xx/6xx & AMD 3xx/4xx/5xx) (https://rog.asus.com/forum/showthread.php?117596-DRIVERS-Realtek-Audio-(MB-Intel-2xx-3xx-4xx-5xx-6xx-amp-AMD-3xx-4xx-5xx)).

Follow scrupulously your CLEANUP process then your INSTALL process, for the next drivers packages that I would release, you will can directly follow your UPDATE process.

Giovy007
11-23-2021, 08:40 PM
I did the scrupulously CLEANUP process then INSTALL process but still no changes as you can see in the new images! Any other way I can do something?

Nate152
11-23-2021, 09:07 PM
Hi Giovy007,

This looks more like windows going awry with the update.

Could always try a system restore to see if the devices come back.

Or upgrade to windows 11, it's free. I'm using windows 11.

90728

Giovy007
11-23-2021, 09:14 PM
can you give me the link for upgrading to Windows 11?

Nate152
11-23-2021, 09:18 PM
Sure, all you need is a 16GB flash drive.

I will suggest doing a fresh install.

Select "Create Windows Installation Media"

https://www.microsoft.com/software-download/windows11

MoKiChU
11-23-2021, 09:22 PM
I did the scrupulously CLEANUP process then INSTALL process but still no changes as you can see in the new images! Any other way I can do something?

You can see that your Realtek(R) Audio device is well installed (in the Sound, video and game controllers category).

If nothing is displayed in your Playback sound devices, it means that you have not (or incorrectly) plugged an audio equipement.

You can see your unused devices by right clicking in your Playback tab and check Show Disconnected Devices.

Giovy007
11-23-2021, 09:26 PM
I did this already and no difference!

MoKiChU
11-23-2021, 09:46 PM
I did this already and no difference!

In this case follow this Microsoft process to run the audio troubleshooter (2.) : https://support.microsoft.com/en-us/windows/fix-sound-problems-in-windows-10-73025246-b61c-40fb-671a-2535c7cd56c8

Otherwise upgrade directly to Windows 11 as suggested by Nate152.

Giovy007
11-24-2021, 12:50 AM
Thank you guys for your help, I did the Windows 11 upgrade and now the issue is sorted, my audio is back as normal!

Nate152
11-24-2021, 12:51 AM
That's great Giovy007,

Thank you for letting us know !