View Full Version : N55SF : lost home Wireless network after recommended update of BIOS

04-16-2012, 12:11 AM
Hi all,

I just bought a new ASUS N55SF 2 weeks ago. After a while I accepted the "recommended updates", which included BIOS and Wifi. Before anyone asks: I was able to do so because he computer was wirelessly connected o my home network.

After the upgrade, I can only see my home network briefly. As soon as I ry to connect to it, disappears from the list of available networks.
So, I tried a drivers update. No luck, same problem.
Then I tried restoring o factory state. No luck. So, since the BIOS is the only hing that can't be resetted, I think of it as the potential problem.
But... there's no way to DOWNgrade BIOS on that machine. Have looked for and tried even afudos... but ASUS Bios files (downloadable from their site) are in the format NAME.VERSION (N55SFAS.203 for instance) and not NAME.ROM

And yes, all other machines at home can see and connect to the network, no probs at all. They are a Win7, a Mac Snow Leopard and a Mac Lion.

Anyone can help/offer some support on this?

Thanks in advance :)

<UPDATE> Just to check, I decided o install OSX on the D: partition. And it connects over WIFi without problems! Same machine, Windows doesn't connect, OSX yes.
What can I do?! </UPDATE>

04-16-2012, 08:50 AM

I guess you're right. After a recommended upgrade I lost my home connection. Still I don't know if the problem is faulty BIOS or the WiFi card.
I decided to install OSX in the 2nd partition and it connects over WiFi wihout problems...
Check the post: http://rog.asus.com/forum/showthread.php?12888-N55SF-lost-home-Wireless-network-after-recommended-update-of-BIOS

Did you change your WiFi card also?
If yes, you need to download the right drivers for the card so it will work as you want it too.
Also if you haven't connected the antennas to the card then that could be the main issue.

Intel Centrino Advanced-N 6230 (http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21143&ProdId=3315&lang=eng&OSVersion=Windows%207%20(64-bit)*&DownloadType=%0ASoftware%20Applications%0A)


Intel Centrion Ultimate-N 6300 (http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21143&ProdId=3408&lang=eng&OSVersion=Windows%207%20(64-bit)*&DownloadType=%0ASoftware%20Applications%0A)

If no and you're still on the stock atheors card, then go to device manager, locate the WiFi card and uninstall it then let microsoft install it again.

Also (not sure which model you have on the atheros card) check out this thread (http://rog.asus.com/forum/showthread.php?5224-Drivers-Apps-and-How-to-s&country=&status=) scroll down and download the atheros driver from there.

04-16-2012, 03:22 PM
Hi, thanks for the reply.

No, I didn't change the card, it's still the stock one.

As I mentioned before, I even tried restoring to Factory. I really doubt it's a driver issue, it seems BIOS.

Following your advice I
- went to device Manager
- under Network Adapters selected and uninstalled the Atheros 9200WB-1NG
- Also selected "delete Drivers"
- Then I old it to detect new Hardware
- Windows automatically installed the driver for my card
- I went to the Wireless Networks icon on my Taskbar, selected my home Network (called "509")
- Windows tried t oconnect and in 5" told me "Windows was unable to connect"
- After that, my Wireless Network never appears on the list of available networks
- If I select someone else's network, I do get the option to try to enter a password. Of course it's a wrong one and I get notified of it
- The strangest is that my home network never appears...

What could be happening?

Thanks in advance

04-16-2012, 04:00 PM
Okey, since it works in OSx and not in Win7 then it is a driver issue. Either that or there is some problem with the WiFi card itself.

Did you try to install the drivers from the thread that I mentioned in post #2 ?

If you still have the problem, I would try (if possible) to buy a new WiFi card either:

Intel Ultimate 6300 (http://www.amazon.com/Intel-Ultimate-633ANHMW-802-11n-Adapter/dp/B0038A9HSK/ref=sr_1_1?ie=UTF8&qid=1334591758&sr=8-1) (without BT)
Intel Advanced-N 6230 (http://www.amazon.com/6230-IEEE-802-11n-draft-Bluetooth/dp/B004PG08SE/ref=sr_1_1?s=electronics&ie=UTF8&qid=1334591926&sr=1-1) (with BT)

Or you could pm @MarshallR and ask him what can cause this issue.
I know that many have complained about the stock atheros cards that comes with these notebooks, and have changed them since it's easy and they give better performance, battery and more stable then the atheros card.

04-16-2012, 06:49 PM
Thanks Fuzon,

I already tried installing the newest driver. The link you gave is v9.1.xxx, and on the ASUS page there's a 9.2 driver for the Atheros Card.
I also thought it could be a drivers issue but... first time I started my brand new computer, it detected my home network, with the stock drivers.
After I got the problem, I restored the machine back to Factory settings. The HDD was reformatted, original drivers, the problem persisted.
Now, the only think that "stays" changed is the BIOS. It's no more he stock one, but the upgraded one. I'd try rolling back to stock version but as I said, Flash utility doesn't accept installing older versions of BIOS.

In my humble opinion, OSX is running WiFi just fine because it uses "fake BIOS". That's why I'm bettng on it.

I already PM'd Marshall and I really thank you for the suggestion. But if you have any further idea, I'd love to hear it.

Thanks again,

04-16-2012, 09:27 PM
Hmm.... just to clear up one thing:

When you say Flash utility, that means Windows BIOS Flash Utility? If you use that one, I would recommend you to use/try another solution to flash your BIOS (I think you will be able to flash back to the BIOS 203 (http://support.asus.com/Download.aspx?SLanguage=en&m=N55SF&p=3&s=352) by useing this suggestion)

The Safer Method to Flash a System BIOS

1. Format a USB drive to FAT32 format.
2. Download the new BIOS and unzip it to the USB drive.
3. Remove USB drive after you're certain the file transfer is complete.
4. Restart your notebook and while the ASUS logo is on the screen press F2 or del a few times to enter the BIOS setup.
5. Find the Easy Flash Utility and insert the USB drive. Tell Easy flash where your BIOS file is then follow directions explicitely!!!
6. When your notebook restarts, enter the BIOS Setup utility again and select "Load Optimized Defaults" (I think it's f9 )
7. Save and Exit, then continue into Windows.

See if that helps to flash back to BIOS v203 :) (unless this is the steps you already have used.... then I'm out of ideas) =/

04-16-2012, 10:21 PM
The easy Flash Utility from BIOS can access any drive, so I had already tried it.

Just to confirm, now I tried installing the BIOS from the USB drive... same message: Warning!! Build Date is too Old!! Please Press Enter to Return!!

I even tried AFUDOS, supposed to be THE TOOL. But it asks for a .rom BIOS file, and ASUS only provides a file whose extension is the version number. So, the curren BIOS file is N55SFAS.207, and the one I'm trying to install is N55SFAS.203
I also tried AMIFLASH (from American Megatrends) but that one asks for a .BIN file

Sincerelly, thank you very much for the effort. There's nothing else than can be tried...?

By the way, this system's BIOS simply sucks. Is an ultra-old castrated one. No access to VBIOS or anything "advanced"

Mate, this is driving me crazy...

04-16-2012, 11:28 PM
So you have seen this post by @BrodyBoy?

Download the correct BIOS for your model, and extract it
Rename the BIOS file to AMIBOOT.ROM, put it on a USB thumbdrive, insert into USB 2.0 port.
Wait at least 15-20 min, or reset the CMOS if at all possible. I would recommend you go to the trouble to do this, even though it's a royal PITA most of the time.
Power up and press CTRL + HOME
The BIOS may reflash from the BIOS file on the USB thumbdrive.

04-17-2012, 12:18 AM
Resetting the CMOS? Opening the Laptop?

I'll try skipping this part.

The rest.. sorry but I didn't understand clearly: I should wait 15-20 minutes after what?

Thanks again, mate, even if t doesn't work I owe you!

04-17-2012, 12:38 AM
Haha, yeah I should have mentiond that just to skip the part to reset CMOS, this was posted due to a issue on the G74 notebook for another member in this forum and somehow this have worked to restore BIOS when it has been bricked...

Not exactly sure me neither but I think he means that you should leve the usb stick in the notebook when turned of for 15 - 20 min then boot up and hit ctrl + home then it would reflash the BIOS with the file from USB thumbdrive.

If you click on the blue arrow in the quote then you can see which thread I found this info from ;)

04-17-2012, 01:29 AM
Well, didn't work either.

I'll plug a 20ft ethernet cable on the meanwhile. If the BIOS is so "user resistant" I guess it's better not get over my head.

It's a defeat not the end of the war, hehe

Thanks for everything, you were extremelly helpful!

04-17-2012, 09:54 AM
I'm sorry for that none of my suggestions worked out for you :(

Then let us hope @MarshallR have a suggestion that will work for you :)