View Full Version : G73S - Big graphic problems. Help me.

04-16-2012, 07:12 PM
Ive had my G73S with Gef 460M for about a month now.
It was a replacement unit för my G73J that was on 3 RMA's and 8-10 weeks in Asus replacement service in Holland.
So its fair to say that im tired of computers not working properly.

When i got the new G73S i right away inserted a SSD and installed Win7 x64 ulti on it.
I then installed all drivers from the disc i got, beside from graphic which i went to nvidia site to download, version 296.10.

It worked fine for a few weeks, no problems at all. Then all of a sudden one day, windows gives me the popup that the driver stopped working and has been "restored". I then started to get blueisch and pinkish apperence in windows, which i sadly forgot to screenshot. A normal reboot didnt help, it came back.

Since then i have tried like 4 different drivers without luck. A few 301.XX from laptopvideo2go.
Together with the latest driver on Asus driver site.
Its pretty calm in Windows. But in movies i can get artifacts, and the moment i start a game, for example Civilization 5, i got big graphicerrors and after awhile the game crash. This screenshot is an example:

If i start 3dmarks vantage, then i get massive graphicerrors with all sorts of colors in the first gametest, then after like 5 seconds of it, the program crash. Heck i cant even run the Windows Index thingy, it also crashed and made the driver stop responding.

Every time i install a new driver i always uninstall everything and then go to safemood to driver sweep the rest, so its no problms there.

Do you guys have any idees? Do i actually have to do a RMA on this computer also?
I havent had a working computer for soon almost half a year, makes me sick to think i payed like 13000 swedish SEK for this...

/ Nicklas

04-16-2012, 09:17 PM

What is the temps on the GPU when it crashes/fails?

You say that you have tried 4 differente drivers, does the beta driver 301.24 include by one of the 4 drivers?
Have you tried this driver? (http://www.nvidia.com/object/win7-winvista-64bit-266.58-whql-driver.html)

I would try to run CCleaner (http://www.piriform.com/ccleaner/download/standard) and run the register check after you have uninstalled the nVidia driver and/or before.

If the problem still occur when you have done a new installation on the graphics driver then it could be a bad paste on the GPU.

Also, be sure to have updated the atheros wifi card, download driver from this thread (http://rog.asus.com/forum/showthread.php?5224-Drivers-Apps-and-How-to-s&country=&status=), since it can cause a lot of issues :S

04-17-2012, 01:54 PM
Shire - are you possibly running on battery power ? If so , try just with regular electric connection . What power plan are you on ? Could be , you are somehow reaching your laptop's power limitations . Did you get anew power brick with your new laptop , or it's the original one ? Have you some power related device between the wall outlet and your power brick ?

04-18-2012, 01:07 PM
Thanks for the replies, but i think its time for me to RMA.

No, no batterypower. I got a whole new package with the computer so i got the things i should.

Ive tired the cleaner and another 2 drivers. Both the ones you posted and a few more. Its the same crap. I cant even start a game before the screen goes complete bizzare...

04-20-2012, 09:58 PM
Bumping this.

So anyway. To prepare for RMA i remove the SSD and did the Asus restore on my XT 500gig disc.
I just installed 3dmarks vantage, and guess what...
It went through perfecly. Am i just lucky? Dont dare to update drivers.

04-21-2012, 12:58 AM
Is it possible that you need to update the firmware on the SSD? I know that certain ones have had issues with Windows 7, and firmware updates, according to some reviews, can work miracles. Also, you could try running on the HDD for a while--if you have time left in your warranty--in order to see if the system will consistently act up, then send it back, so that they will see what is going on.

04-21-2012, 01:10 AM
I suspect you encountered the reported "pink screen" issue for the NVIDIA 296.10 driver (see http://rog.asus.com/forum/showthread.php?12190-g74sx-3D.-Screen-turns-a-static-Pink-out-of-nowhere.).

I also suspect this issue corrupted the NVIDIA registry (and/or core system files) and failed to uninstall properly. This corrupted remnant continued to cause problems even after multiple NVIDIA clean installs. This corruption was finally removed when the entire Windows registry was recreated during the OS reinstalllation.

A Windows System Restore to a time prior to NVIDIA 296.10 driver installation would've provided the easiest way to eliminate all traces of the problem video driver. A restore of the previous Windows System Image from a prior backup would be the next best solution.