PDA

View Full Version : G74sx - Intel Turbo Boost ruining my day (CPU spikes causing constant lag/spikes)



dataDave
04-29-2012, 03:34 AM
OK, this is really winding me up.

When playing certain games my FPS drops from 60 all the way down to 0, waits a second or so, then shoots back up to 60.

This is of course the good old Intel Turbo Boost kicking in, as confirmed by the monitor.

Is there any way to get it running in Turbo mode permanently? This is really screwing up my SC2 battles where I need to micro during 'elevated' action events. When I play a 4v4 that really maxes out the system I don't suffer any spikes at all because the CPU is constantly OC'd. 1v1 games have CPU spikes/lag all over the place and it's totally unplayable. Even with all settings on low.

Tried all the Windows high performance power options (asking it to max out my CPU no matter what) and of course Asus P4G Hybrid. They both don't do diddly zip.

Any solution to this? It would be nice to be able to control this from the BIOS but of course the BIOS on the G74SX has about as many options as a Fisherprice laptop.

fostert
04-29-2012, 03:43 AM
Love the Fisherprice laptop reference...very apt! ;)

Try ThrottleStop, which has an option to turn off Turbo boost, thereby running your CPU at a constant 2.0/2.2 GHz (for the 2630 and 2670 respectively). However putting the CPU in a permanent overclocked state is not possible with throttlestop or the current BIOS in the G74. It is simply not an overclocking friendly BIOS, and besides, I think on the QM series CPUs the multiplier is locked, so these can't easily be overclocked without messing with the FSB speed, which would OC everything based on it with a multiplier.

dataDave
04-29-2012, 04:47 AM
Hi Foster,

Thanks for the Throttlestop recommendation. Didn't know it could throttle as well as clear throttle. :) For games that push the system then Turbo is fine, for borderline up + down stuff like this it's a nightmare. Looks like I will need to lower some CPU heavy options to keep my 60fps, which sucks knowing it could boost constantly if the option was there.

unclewebb
04-29-2012, 03:21 PM
The problem is not Intel Turbo Boost. The problem is likely clock modulation throttling that is used to slow your CPU down to sluggish speeds, usually when it decides that your GPU is running too hot.

You need to disable BD PROCHOT if you want to get this problem under control. That eliminates the communication link between the GPU and CPU and prevents this type of throttling. Run some ThrottleStop log files while gaming so you can better understand this problem and do some Google searching about BD PROCHOT and Asus gaming laptops like the G53 and G73.

dataDave
04-29-2012, 06:16 PM
I disabled the BD PROCHOT as soon as the laptop arrived.

When running windowed, along with the cpu monitor, the lag spikes are synced with the turbo boost kicking in, then also synced when reverting to non-turbo.

Not tried Throttlestop to turn off the auto turbo boost yet, but I have been running some CPU dependent applications in the background whilst playing to keep things in turbo mode, that works but it's not ideal.

unclewebb
04-30-2012, 12:00 AM
Clock modulation throttling can instantly kill Turbo Boost and drop your CPU down to 800 MHz. This "feature" can continue to throttle your CPU internally so it is not even running at that speed. Your FPS will drop like a rock the moment this happens and will instantly speed back up the moment this feature is turned off.

Your best bet is to run ThrottleStop with the Log File option checked so you can figure out exactly what is going on. Go do some gaming for a while then exit your game and exit ThrottleStop. Copy and Paste the data in the log file to a site like www.pastebin.com and then post a link here so I can have a look.

You are blaming the Turbo Boost feature but I think it is clock modulation throttling that is the real problem like it is in many other Asus gaming laptops.

Once I see some data then I can suggest how ThrottleStop should be set up to take care of this problem.

Clock modulation throttling is usually triggered by excessive power consumption or your GPU temperature. Enable GPU monitoring in the TrhottleStop options tab so that data will be included in the log file. If your GPU is running too hot then you need to find a way to improve cooling so you can run your laptop at the speed it was designed and advertised to run at.

dataDave
04-30-2012, 03:34 AM
OK mate, I'll try that tonight and post the results here to see if anything is happening.

When I max the settings on the graphics (mainly the shaders) the FPS drops to an understandable 50-55 constant rate, as well as the dips to 0 then back up to 50-55 1-2 secs later. Lowest settings get me 60fps with the same dips.

I'm reading posts elsewhere that an old nVidia driver (2.50) can resolve the issue although I've yet to try that.

These dips also happen when I'm navigating the main menus.

dataDave
04-30-2012, 06:23 AM
On further research there are A TON of people with this exact same problem, and the apparent fix is to roll back the nVidia drivers in safe mode whilst de-selecting everything (PhysX, HDAudio, etc). Once the problem has gone you can then install the latest PhysX from guru3d.com.

I'll try this first before getting all technical. :)

dataDave
04-30-2012, 01:54 PM
Woohoo! Fixed it with the driver reinstall minus that nvidia bloatware crap. I noticed I was still getting a little throttle here and there so lowered my sound options both ingame and on the realtek console and that cut the throttling down even more.

Only tried one 4v4 so far but the only time it really dipped was during large-scale kickoff.

Would it be too hard for Asus to fit a dedicated sound board in one of these rather than it being software based running off the processor?

dataDave
05-02-2012, 06:33 AM
OK, They came back... :(

But I fixed it. Went to processes and right-clicked the SC2 exe then set the affinity to CPU 0 and 2 and turned the rest off. No more hyper-threading or jumps/skips/lag/stutter. Sound back up to full quality.

CPU 0 was doing 96-100% of the work prior, with some load being spilled over to the other cores. Now, both 0 and 2 share the load equally.

Seems it's optimised for dual core processors, the upcoming expansion is going to utilise quads as well as hyper-threading apparently.