PDA

View Full Version : ASUS G73S - Freezing issues



Warden50
05-11-2012, 03:35 PM
Hello,

I bought my Laptop in August 2011 (not so long ago) , it's an G73S and it worked perfectly on all my games so far. But about two months ago I started to have issues with game freezing (screen is blocked from 1 to 5s) on some games and even on desktop. I tried the tutorial on your forum about flashing BIOS but it did not helped. I also tried to reset my entier computer (windows fresh install + drivers only from ASUS Teck support) but still not working properly. The weird thing is that I put the settings to their maximum on games like Battlefield 3 , TERA or Guild Wars 2 without any freezing issues, but on "older" games like World of Warcraft , Lord of the Rings online or Dark age of Camelot it freezes every 5s. I checked the entier world (yes I did ! ) , I tried hundreds of solutions but still the same. This forum is my last chance otherwise I will have to bring it back and that would be very frustrating.

Does somebody can help me ?

Thank your in advance (and sorry for my poor english , this is not my mother tongue).

Sincerly yours ,

dstrakele
05-11-2012, 03:41 PM
Have you run DPC Latency Checker?

What WiFi card do you have? What version WLAN driver are you running?

What make and model HDD(s) do you have?

Warden50
05-11-2012, 03:57 PM
I havnt run DPC Latency Checker.
My Wifi card is (I guess this is it) an Atheros AR9285 Wireless Network Adapter. About the WLAN I dont know how to get it.
My HDDs are both (got 2x500Go) : ST95005620AS from Seagate Technology LLC. (After a quick search on the web they are also called Momentus XT 7200). I already tried to update the Firmware of these HDDs but didnt worked either ^^.

dstrakele
05-11-2012, 04:10 PM
Go into Device Manager and expand "Network Adapters". Right-click on your Atheros Wireless Network Adapter and choose "Properties" from the popup menu. The "Drivers" tab will display the version of your Atheros driver.

Check out this thread: http://forums.seagate.com/t5/Momentus-XT-Momentus-Momentus/ST95005620AS-very-laggy-in-games/m-p/150533

What version firmware is currently installed on your HDD's?

Warden50
05-11-2012, 04:16 PM
First of all thank you very much for you time and your quick answers , well my driver version is 8.0.0.316 for my Wifi card. Dont know if it helps you.

dstrakele
05-11-2012, 04:19 PM
You want to upgrade to version 9.2.1.470 or later (http://dlcdnet.asus.com/pub/ASUS/nb/Drivers/WLAN/WLAN_Atheros_Win7_64_Z921470.zip). The earlier Atheros drivers have bad DPC Latency.

Warden50
05-11-2012, 05:06 PM
Allright I'll do it , do you want it my troubles might comes from it ? I'll make some tests with new Driver and keep you up. Thank you so far ^^

dstrakele
05-11-2012, 05:19 PM
DPC Latency can result in the brief freezing behavior in games you report. There may be other drivers contributing to DPC Latency, so it is a good idea to run DPC Latency Checker.

If you still experience this issue, the firmware version in your HDD's could be another possible cause.

Holy
05-11-2012, 06:32 PM
Gw2 kinda favors the cpu over the gpu. They need to optimize it for the gpu.

Warden50
05-12-2012, 08:16 AM
Well I launched a Latency test this night and , indeed, I have huge spikes at some moments when I play. I tried to disable/enable many components but it didnt fixed the issue. However I read something similar on an other forum and I have copied games encountering these freeze issues on my second HDD (wich is also a Momentus XT) and it seems to work fine. Maybe the problem is more a hardware problem with my first HDD.

Anyways thank you all for your help and support.