PDA

View Full Version : Several G73JH-A1 bricked yesterday. No POST, no video, not booting.



rgbellemare
05-13-2012, 12:09 AM
Edit: We did not unduly use the laptop. No BIOS flashing. I was loading a bluray disc when it happened.

Hi all,
Myself and 2 other people have reported the same bricking G73JH yesterday over in notebookreview.com forums. Here are the symtoms on our G73JH's:
Not sure about link posting rules: http://forum.notebookreview.com/asus-gaming-notebook-forum/662632-need-help-g73jh-no-video-wont-post.html

1. Nothing loads (no OS, no BIOS)
2. No sounds
3. No Post
4. Black screen, no video
5. All lights turn on, but laptop is quiet (power, 3Rog buttons, keyboard, screen underglow). After ~15 seconds, fans powerup to 100%
6. If AC and battery are plugged in, we get the battery charged green light

I've searched the forums and no one else has reported something exactly like this in the past. User Yentoo here reported something similar here: http://rog.asus.com/forum/showthread.php?11968-G73JH-Black-screen-(/page2

What I've done to troubleshoot:
1. Undercarriage reset button
2. 30 second power button hold while battery and AC are unplugged
3. Boot with/without HDD, reseat HDD
4. Boot with/without RAM, reseat RAM, swap RAM
5. Complete disassemble of laptop to look for scorching. Reseat everything including GPU.
6. Fan cleaning (hey, might as well while the laptop is apart right?) BTW increase fan throughput immensely :)
7. Boot on AC, battery, none, both.
8. Remove bluray player

Anyone else experience the same thing? 3 laptops bricking in a previously unreported way on the same night sounds kind of fishy.

evga
05-13-2012, 01:49 AM
you smell like a NBR guy!!
AS I said before , the problem comes from VGA.

rgbellemare
05-13-2012, 04:00 AM
Yeah at this point I think you're right. When trying to boot up, the copper tubes for the CPU get warmed up, while the copper tubing for the GPU remains cold.

How would you suggest resolving this? I've been searching the forums and it's not clear if I can upgrade the GPU. There's an Asus service center in my city that I could bring it to. Should I bring it in for repairs, find a replacement unit, or find some compatible upgrade? FYI I'm a computer engineer, so I'm perfectly comfortable doing this myself. I'm mainly concerned with cost and downtime.

nxs82
05-14-2012, 02:13 AM
It happened to me 2 months ago.
Here's my NBR thread:
http://forum.notebookreview.com/asus-gaming-notebook-forum/653601-asus-g73jh-will-not-turn-post-no-screen.html

Seems to be a dead GPU. Could someone link me to the correct videocard, I am finding some dell and clevo ATI5870s on ebay and I'm not longer sure what to buy....

I am very upset with ASUS, they deny giving me any kind of support down here in Argentina because I bought the laptop in USA. And I thought I was getting a WORLDWIDE WARRANTY....

I wish all of us good luck with the repairs! :)

EDIT: found this vendor on ebay:
http://www.ebay.com/itm/New-Asus-G73JH-video-card-ATI-5870m-/160801766002?pt=PCC_Video_TV_Cards&hash=item2570883a72#ht_500wt_1413

Is this the right video card for the G73jh? A lot of ebay items are misleading and want to make sure before I spend the money...