View Full Version : Disable webcam lowlight filtering?

01-31-2011, 09:44 PM
I was wondering if there was any way to disable the webcam filter or preprocessing, whatever you wish to call it. With default settings, the webcam seems to record at 1-2 FPS with a 1-2 second delay. Having seen something similar with cell phone cameras, I figured maybe there was a low light filter being applied which was slowing down the capture.

So I tried taking an LED flashlight and shining it directly at the camera; the filtering scaled down until the flashlight wasn't flooding the screen and the FPS became very high and there was no perceivable delay in the capturing. The obvious problem being that half the capture ends up being the flashlight. But it proves that there is low light filtering present and it is hugely impacting video capture. The part that isn't being obscured by the flashlight isn't even that bad looking.

The only options I can find are on this Video Proc Amp tab; which while seems to affect the capture in real time, it doesn't turn the filtering off. I've tried the newest drivers for the camera that were available when I got the system plus some that are listed on a sticky here(which are a year older). I tried installing the Virtual Camera software, but that device ends up being even more delayed.

I get the same results in Skype and the TWAIN(maybe) interface spawned by Microsoft Office Document Imaging.

G73Jw-A1(v202 BIOS) (TigerDirect)
USB2.0 UVC 2M WebCam

02-01-2011, 05:21 AM
Another user (or maybe it was you) has the same issue with the same camera model as described in the thread at this link (http://forum.notebookreview.com/asus-reviews-owners-lounges/456659-asus-n61jq-owners-lounge-603.html#post6658845).

FWIW, there's a driver on the Asus download site (link) (http://support.asus.com/download/download.aspx?model=Camera&os=30&SLanguage=en-us) for your camera model (VID_13d3&PID_5122) dated Jan 25 2011 version V5.8.55133.208. Have you tried that?

I'm not sure if it's just that camera model or a software issue. The camera on my G73JH certainly doesn't have any issues but it's a different model from a different vendor ID...I would have noticed right away as I develop camera software. I can get 30FPS up to 800x600 and 15FPS up to 1600x1200 (2 Megapixels) with no more than the usual <1S latency in preview.

To rule out software you could try this app called AmCap (link) (http://www.arcstren.net/amcap.zip)...it's a DirectShow demo app from the Windows SDK so the UI isn't pretty but it uses the camera raw - no filters or frills. You can try different resolutions and frame rates to see if it's any better than the capture apps you've tried.

02-02-2011, 06:06 PM
Despite the package date, the internal driver date is the same as the first driver that I used -- 10/6/2010. The version is what you listed.

The demo app linked shows the exact same results with more or less the same configuration settings as the image capture interface. None of the sliders will disable the automatic light adjustment.

For giggles I updated the BIOS to 203. No change.

02-02-2011, 06:58 PM
Well, I know to avoid THAT camera model...

The only thing I would do in your situation is go into the registry and see if there's any settings that can be disabled/enabled.

To find the camera's registry section you can use device manager on the details tab for the camera device. Get the "Driver key" property value and find it in the "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class" section of the registry. Then drill down into the settings key(s) and see if there's any enable/disable values in there that you can try changing (e.g. from 1 to 0 or vice-versa)...may require reboot after changing values.

Good luck! :)

02-04-2011, 07:01 PM
Thanks, that's a pretty good idea; though I'm not sure it'll work out in the end.

There's a DefaultSettings node with a value named, "LowLightThd" with a value of 0x50. Obviously not a toggle and the INF puts the setting with other de-noise options. The options are not immediate, but any camera UI with a "Default" button will seem to apply the changes in this node. That said, I'm not having any particular luck so far.

02-04-2011, 08:50 PM
... I'm not having any particular luck so far.

Bummer. I wish I had a larger sampling of owners of that model camera to make a better determination as to whether it is software related or inherent to that model.

You may want to try asking over at NotebookReview.com (http://forum.notebookreview.com/asus-gaming-notebook-forum/) to see if others have experienced the issue (others besides the one I linked to).

02-09-2011, 02:56 PM
I also have hard times to get 5-6 fps using multiple drivers/software... What I found is this USB tool (ftp://ftp.efo.ru/pub/ftdichip/Utilities/UVCView.x86.exe). Ran it got some errors like

bDeviceClass: 0xEF
*!*ERROR: Multi-interface Function code 239 used for device with no IAD descriptors
bDeviceSubClass: 0x02
*!*ERROR: bDeviceSubClass of 2 is invalid.

I have no idea what does that mean, of course... :D

G73JW-3DE, BIOS v203
USB2.0 UVC 2M WebCam (Azurewave, Sonix driver)

01-06-2012, 11:49 PM
Im having the same issues with extremely low fps , and there is no chance fixing it so far,
on notebook Asus N61 ,
same webcam model

Asus USB2.0 UVC 2M WebCam
producer/ driver: Sonic

it is very common because there is something wrong

03-11-2013, 02:27 AM
Has anyone figured out a fix for this yet or should I just go buy a webcam that isn't stupid?

03-11-2013, 05:27 AM
i think if you think wecam have not high fps, i think you should be buying other wecam.