View Full Version : G75 - No Dual Band on wireless

Michael Khalsa
05-22-2012, 12:32 AM
I recently purchased a G75 -VW from best buy, uped memory to 16GB and a samsung 830 256 gb ssd. Realy like it. I use it mostly for software development (large builds, heavy visual studio)
Runs very cool and quiet.

I was under the impression that it had wireless n- dual band (as per asus specs), however it only shows the 2.4ghz wireless ssd (no 5 ghz).
On looking up the chipset Atheros on the manufacturers web site, it also only shows it as a single channel 150 mhz bandwith at 2.4 ghz

Am i missing something, or is some of the G75VW laptops dual and some single n-band wireless

This is being used on an Asus N900 dual band router (greate router)


Another question - i noticed the laptop has the 3D screen button next to the power button. Does this mean that if i purchase 3D glasses it is 3D ready for movies and games.


Michael Khalsa

05-22-2012, 12:53 AM
For 3d you would also need a 3d reAdy external display.

05-22-2012, 03:45 AM
From the specs page (Products-Notebooks-G75VW): Integrated 802.11 b/g/n

This states it's only single band wireless N (150Mbit), not dual band N300+ sorry. Any reference to 'dual' in the marketing material is because the same card also does Bluetooth 4.0 too. Very sorry if this has caused confusion.

Which model did you buy exactly? If you bought the 3D model it should already come with 3D glasses.

05-22-2012, 04:41 AM
Since you bought the Best Buy version, that 3D screen button next to the power button only cycles through the different power setting profiles of Power4Gear. The screen that comes with the Best Buy G75VW is not 3D enabled, so even if you get 3D glasses it won't work.

MarshallR: Can you confirm for the public that 3D glasses + a 3D-ready external display (or HDMI output to a 3D-enabled TV) would work?

05-23-2012, 08:48 AM
It should do over HDMI or DP (not VGA though I expect), because it's a direct connection to the Nvidia GPU inside. I've not got a spare external 3D display to check sorry.