View Full Version : G74SX-NH71 with Kingston 1866 PNP

05-29-2012, 01:10 AM
Hello I was just wondering if anyone has had any sucess with the Kingston HyperX 1866 ram. I have tried it ,and it fails prime 95 off the batt. I have an I7 2760 that I installed and it will run the kingston 1600 fine. I am seeing places where they are offering this option with the i7 2670 with a 1333 mem controller. I am just wondering how they are getting this to work.

When I put it in my G74 it only works in the bottom 2 slots DIMM 1 A and B. If I put it in the top 2 slots DIMM 0 A and B it will not boot. I find this very strange. when in the bottom 2 slots it says in the ram info pc 14200 889.5 MHZ but its running at 933 MHZ. thats telling me that 889MHZ is the max of the mem controller but its running at 933MHZ. I dont get it. I wish ther was a bios mod.
Any thoughts?

05-29-2012, 02:06 AM
1866 RAM is much harder to run than 1600. While the Intel IMC's are tough, they aren't binned (in the notebooks anyway) to run those speeds natively. They require XMP configuration to run properly at those speeds. Even 1600 is very hard to run in 4x4 config. In my experience here, only one person ever achieved that, and then only through BIOS modding and a lot of hard (and risky) work. Not worth it, IMHO, just run 1333 RAM, it's fast enough for everything you need to do.

05-29-2012, 02:16 AM
Actually, the 2630QM should support it. According to some owners, they upgrade 4x4 hyper kingston x 16GB on their G74 and so far they haven't had issues. So i donno.

Where did you bought those rams? and try to reset ur BIOS settings. if not check if you have the lastest BIOS update

05-30-2012, 01:58 AM
Hey guys, thanks for the responce. I have the latest bios and it is set to default for what few options there are. Just to let you know I am only running 8 gig config. 2x4 . I think that 16 is to much for the mem controller on the cpu. The laptop came with an i7 2670 and it ran the ram at 1600 mhz in the bottom 2 slots stable only. The top 2 it would BSOD, so thats 266 mhz over a 1333 MHZ that was possible to run in the bottom 2 slots. Then I put a 17 2760 that has a1600 mhz controller. I tried the 1866 .Again 266 MHZ over the processor. No dice.

I have RMAed the ram 5 times , so I know its not the ram. I talked to the people at Kingston and they said that the ram should clock down to the max of my memory controller. With the current processor in there it says 889.5 max, but its running at 933MHZ I find this to be very strange. The bad part about this is that I dont have a real understanding of how the board really works. Asus is not apt to give out information on there laptops and how they work. Its a completly different story with ther desktop boards. I understand the basics of the HM65 chipset, but Intel says they sell it to Asus and they can modify it however they wish to,so I guess were flying blind here.

Anyway I am running 1600 MHZ PNP stable so I am never looking back to the 1333 Just looking for the 889.5. I know that they are selling these laptops with 1866 as an option, so I was just wondering if anyone out there is running at thet.


05-30-2012, 11:12 PM
I tried running Hyper-X 1866 2x4GB and no luck. Would BSOD all the time, gave up and got a refund. It's a hit or miss it seems with the G74.