PDA

View Full Version : Asus G74 screen flicker (dark backgrounds and low brightness) [FIXED]



380mcn
05-30-2012, 04:38 PM
6 months later, my fellow ROGers the flickering is no more.
Thanks to ny2lond from romania that says:

Open Nvidia Control Panel ->Adjust desktop size and position and select full screen.

Next, go to change resolution -> Customize -> Create Custom resolution -> Type 67 in refresh rate. Make sure Scan type is set to Progressive and hit test. If all works well, select yes.

* * * After this, there should be a Custom with you creation, above PC list. Select it, press the drop-down list and select 67 Hz with 32-bit Colour depth and hit apply. Close Nvidia Manager

* * * Hit Right Mouse Click on windows desktop > Screen Resolution > Advanced Settings > Monitor Tab > Screen Refresh Rate > 67hz! > APPLY

And the flicker is no more!


Once again thank you NY2LOND! (his full post is here (http://rog.asus.com/forum/showthread.php?5536-Asus-G74-screen-flicker-(dark-backgrounds-and-low-brightness)&p=108570&viewfull=1#post108570))
P.S. I created a new thread because i couldn't edit the subject on the 1st thread and because i think this should go to sticky!

OldNESJunkie
05-31-2012, 02:02 PM
Replied on the other thread already, but anyways:

Yahoo, it does indeed work. In fact I was able to set my monitor to 75hz refresh rate set to Progressive. MUCH better. I thought about trying this but never got around to it because I was under the assumption this LCD panel would only support 60hz. In Device Manager my panel says "MONITOR\LGD02D1".