View Full Version : Windows8 A no go, need help recovering system

05-31-2012, 05:17 PM
system: G74SX-1aty
bought from newegg.com

From the day I received this system I had various issues. Most notably frequent wireless connection drops. So I thought I'd start with a clean install. I changed out the hard drive with a seagate 500G hybrid drive and enabled UEFI and installed windows8 which gives you very fast boot with UEFI enabled. I work at MS on windows8 so I thought I'd be able to get things to work as drivers from win7 should be mostly compatible.

This was a big mistake. There wasn't drivers for the touchpad on the web site and the upgrade software wouldn't work. I found Sentienel drivers for the touchpad which seems to be correct and the latest version, but they didn't resolve the issues. It is almost impossible to use the keyboard with this touchpad as it continually thinks you are tapping. I didn't encouter this issue with the system with the factory image on it.

So now I just want to go back to windows7, but don't want to spend 50 bux for the recovery DVD. Has anyone started from a clean install of windows7? Any reccomendations?


05-31-2012, 05:26 PM
Install Windows 7 from DVD.
Keep the 30gb partition (it's the Asus Express Gate Cloud linux)

Install all the drivers. nvidia, realtek, sentellic/synaptics etc etc,
Install only Asus ATK package (controls the fn keys and keyboard backlight) and Wireless Console (to switch between wifi on/off bt on/off)

have fun.

05-31-2012, 06:49 PM
Here's a post in a thread that should help you get started with a clean Windows 7 installation: http://rog.asus.com/forum/showthread.php?9051-Asus-G74SX-Clean-Install-Clear-ups-and-Doubts&p=60902&viewfull=1#post60902

Feel free to ask any questions.

05-31-2012, 09:35 PM
Still having issues with the touchpad driver. Can't disable tap :( and mouse cursor disappears when typing and doesn't come back until i've plugged in an external mouse? this is killing me.

thanks for all your help so far guys,

05-31-2012, 09:40 PM
About the touchpad issue, go to device manager and find out if you have the Sentelic or Synaptics touchpad.

Then uninstall the current driver and reboot and let microsoft install it's plug'n'play driver.

After that download the right driver from here:


Sentelic Touchpad (http://dlcdnet.asus.com/pub/ASUS/nb/Drivers/Touchpad/vista/Touchpad_Sentelic_Win7_64_Z9135.zip) - Recommended
Sentelic Touchpad (http://dlcdnet.asus.com/pub/ASUS/nb/Drivers/Touchpad/Touchpad_Sentelic_Win7_64_Z9177.zip)

Synaptics (http://dlcdnet.asus.com/pub/ASUS/nb/Drivers/Touchpad/Synaptics/Touchpad_Synaptics_Win7_64_Z153170.zip) - from Asus FTP (excruciatingly slow)
Synaptics Scrybe Driver v 15.2.20 (http://drivers.synaptics.com/Synaptics_v15_2_20_C_XP64_Vista64_Win7-64_Signed_Marketing_SGS94_UI-Scrybe.exe) - from Synaptics

Install the right driver and see if that fixes you issue :)

05-31-2012, 09:45 PM
i installed:
Sentelic Touchpad

i'll try the other version


05-31-2012, 11:03 PM
It's important to install the correct driver. Otherwise the touchpad will not perform correctly. A Synaptics driver installed to a Sentelic toucpad will make it appear to be a Synaptics touchpad in Device Manager.

I recommend you uninstall your current touchpad driver from "Control Panel - Uninstall a program, REBOOT, and Windows will install its Plug-n-Play touchpad driver. THEN go into Device Manager, right-click on the touchpad device and choose "Properties" from the popup menu. Select the "Details" tab.

When you choose "Hardware ids", what is displayed in the "Value" section. I believe if it has "STLC" in the value, it will confirm you have a Sentelic touchpad. If the Hardware ID is different, you have a Synaptics touchpad.

Once you know which; install the correct driver from the links @Dixon provided. I recommend if you have a Sentelic touchpad.

06-01-2012, 12:48 AM
the hardware id is:

I originally tried the synaptic drivers but they did not recognize the device (no device found). The Sentelic driver was a disaster. I was not able to disable tapping and often the mouse pointer would just dissapear on me.

I'll try your suggestion, but i'm guessing i'll run into the same issue when I try to install the synaptics driver.

Thanks again for your help,

06-01-2012, 12:55 AM
after verifying that it was indeed a synaptics device i continued to get the same error from the setup program, but when I ran dpinst directly from the x64 directory it worked and now the touchpad works as it should... probably could have kept windows 8 on the machine and benifitted from UEFI boot!!:eek:

06-01-2012, 06:17 PM
I just put the Windows 8 Release Preview on my G74, and it's working great, boots up in under 10seconds with my SSD :P But I had issues with the touchpad driver as well, I have the Sentelic one. I tried running the setup and it said that I did not have the right drivers for the system, so I went into device manager and right clicked on the PS/2 Compliant Mouse and updated it myself, and chose the driver from the Sentelic folder and it worked perfectly first time through :D Just thought I'd put this for anyone else who has issues, so manually installing your touchpad driver will work if the setup.exe file doesn't.