PDA

View Full Version : G53SW Throttle stop not working!



schn00gins
06-02-2012, 03:47 AM
Hey everyone,

So I am trying to use throttlestop to keep my multiplier at max, but when I turn on throttle stop, it doesnt change a damn thing. It still accurately monitors everything, but it isnt changing my multiplier to the max. Can someone tell me what my Issue is?

I have everything UNCHECKED except Set Muli (@28), log file, and EIST.

I've tried checking clock mod and chipset clock mod while at 100% and that also does nothing.


I have my throttlestop folder on my desktop, and I figured it that if that was an issue then I wouldnt be able to monitor my CPU at all.

So what gives?

unclewebb
06-02-2012, 04:54 AM
I think your issue is that if you do not have an Extreme processor, you can not lock it to a fixed multiplier like you would like to be able to do. This is a limitation of Intel's non-Extreme mobile CPUs. It's not a limitation of ThrottleStop.

What CPU model do you have? How about a screen shot of ThrottleStop that shows the problem you are having? The ThrottleStop Set Multiplier feature should be set to Turbo for most Core i5 and Core i7 CPUs.

Edit: Here's what a 45 multiplier looks like on a second generation Core i Extreme mobile CPU.

http://img585.imageshack.us/img585/6827/4494mhz.png

schn00gins
06-02-2012, 08:22 AM
I have the i7 2630QM processor

Your screen shot is EXACTLY what I am trying to achieve--all cores at a locked multiplier.


My issue is that all of my cores are consistently changing depending on the load, instead of staying consistently at the multiplier I want

http://i84.photobucket.com/albums/k39/Schn00gins/Untitled.png

unclewebb
06-02-2012, 01:21 PM
You do not have an Extreme processor. They are the only mobile processors that can run at the maximum Turbo Boost multiplier. If you want to lock the multiplier, you need to install either a Core i7-2920XM or a Core i7-2960XM.

The default multiplier for a Core i7-2630QM is 20. There is a registry hack that you can do which will lock your CPU at 20. The hack disables the C States but that also disables Turbo Boost since these two features are related. Your laptop will run hot as hell when idle and your CPU will run much slower because Turbo Boost will be disabled. This is not something that most laptop owners are interested in doing.

schn00gins
06-02-2012, 05:21 PM
Well that is moderately depressing, but I appreciate your help.


Im assuming that you would have presented an ultimatum to locking the multiplier if there were one?


EDIT: A GOOD ultimatum that is actually beneficial.

unclewebb
06-02-2012, 10:29 PM
The Intel Turbo Boost feature works great. Unfortunately, it is misunderstood and often times gets blamed for a lot of problems that users have. Many of these slow downs are caused by manufacturers deciding to randomly throttle the performance of the CPU. This is usually due to them setting a temperature threshold far lower than what Intel recommends. Some manufacturers deliberately throttle the CPU because they have not included an adequate power supply to fully power both the CPU and GPU while gaming.

If you are a gamer and are having problems while gaming, run ThrottleStop with the Log file option checked and then you will have an accurate record of your CPU's performance. When finished playing, exit the game and then exit ThrottleStop. You can copy and paste the log file data to www.pastebin.com and then post a link here if you would like me to have a look.

Some G53SW laptops have had premature throttling issues so it is always a good idea to do some testing if you suspect a problem. You also need to make sure your CPU heatsink and fan are clean and properly attached.