PDA

View Full Version : Problem with USB 3.0 and Razer Naga Epic



kiba
06-04-2012, 11:52 AM
I have a regular razer naga that I've been using for years, the software for it works great for it on all of my laptops including the G75(strange). Since my gf started playing MMO's and learned on the mouse, I decided to give it to her and get a razer naga epic to replace it. The mouse works great, looks great etc... but the software which lets you customize the buttons, lighting colors and whatnot does not recognize the mouse, it says
"No Razer Naga connected. Application will close now."
I tried it with the dock, and also plugged the cord in directly, but still nothing. I installed the software on the desktop and also my other two laptops, and it works fine on all of them. Since the G75 has all USB 3.0 ports and the others have 2.0, I figured it might be a problem with that, but i dunno. I know that if I update the USB drivers they will go kaput on me so thats a no-go. The mouse works, like I said, I just cant customize the buttons, which I do for certain games on occasion, so its not an urgent issue, but any help would be, as always, much appreciated.

kiba
06-05-2012, 04:10 AM
anybody have this mouse? or a similar issue?

Holy
06-05-2012, 04:14 AM
i would actually buy one and test but i would not receive it in time(going out of town for the summer thank god its hot in Texas)

kiba
06-05-2012, 05:55 AM
have fun on your vacation, i wouldnt want you to buy a $120 mouse to have the same problem as me.

Holy
06-05-2012, 05:43 PM
i also have a gaming desktop and a g73sw to try on lol

nightman1701
06-05-2012, 05:45 PM
I had a similar issue using the Star Wars TOR Gaming Mouse on my G73. If I installed Synapse on other computers and connected the mouse it would work. If I tried to use it on my G73 it would not detect it. After hours of troubleshooting it I determined that it was a driver issue. I only got it to work by doing a fresh install of Windows.

How I determined it was a driver issue was I had another Star Wars TOR Gaming Mouse before this one that did not work at all after updating it. I think somewhere trying to uninstall Synapse after the bad updates something from Razer did not remove correctly which is why I was having trouble getting my new mouse to work.

The only reason I did a fresh install was because I had order the G75 and was waiting on it to arrive so I figured I would give it a shot. Being that it worked on all the other computers that I have here at home and at work and also when I did a fresh install. I think it was just a driver issue.

It would say that it had the Razer Common Driver installed but Synapse would not detect the mouse or dock and it still did not function. After the fresh install it worked fine and it worked fine when I plugged it up to my G75. I don't know if maybe there is an issue conflicting with it from the old Naga that you had. See if you can restore your computer to a point before you plugged up the Naga Epic and then uninstall synapse and try again. Maybe that will work. I didn't have much luck with Razer Support besides hem telling me to wait for updates to fix the problem.

Let me know how you make out. Good Luck!!

dstrakele
06-05-2012, 05:56 PM
1) Did you see this page: http://help.razersupport.com/us-en/resolution.asp?sid=141156120605068099141211&pid=400000454&pnm=Razer+Naga&seid=400002712&pos=Windows&top=Synapse+2%2E0&rid=400004308

It states:

Q: I downloaded Razer Synapse 2.0 and now when opening the configurator I receive an error saying that no mouse is detected.

A: Please be sure you are opening the Synapse 2.0 driver and not the traditional driver. Once you have download Razer Synapse 2.0 you should be using Razer Synapse as the exclusive driver interface for your Naga. You should not attempt to use the traditional driver once Synapse 2.0 is installed.

2) Have you installed the latest Razer Naga Epic firmware?


3) Otherwise, I think you are heading down the right track with USB 2.0 vs 3.0 support. Is it possible to enable "USB 2.0 Legacy Support" in the G75 BIOS?

jdog1473
06-06-2012, 04:33 AM
I have the naga epic.

I did notice that even though windows said "successfully installed driver" it did not work until I installed the driver and app from razer.

Other than that it has worked flawless...man do I love this thing.

Marinesrule1980
06-06-2012, 05:17 AM
I have noticed that with the new driver it makes me log in to the mouse software to do any button programming.

kiba
06-06-2012, 02:58 PM
i did updadte the firmware on the dock and the mouse as soon as i got it, but let me try some of the other things you guys suggested and post progress.

kiba
06-06-2012, 07:16 PM
yeah, i tried everything, even a system restore, but still,
"No Razer Naga Detected. Application will close now."
:(

kiba
06-08-2012, 10:40 PM
grrr this is frustrating, i guess i am just going to get the new naga 2012 for this laptop and use the epic for my desktop.... unless of course anyone has a solution *hopefully waits*

Joejam701
06-09-2012, 08:26 AM
have fun on your vacation, i wouldnt want you to buy a $120 mouse to have the same problem as me.

what brand do you buy? ... Razer mamba mouse ???:confused:

macq
06-09-2012, 06:01 PM
Did the Razer have 64bit software and, if so, did you install that (rather than 32bit)?

kiba
06-15-2012, 07:17 PM
sorry, i havent had much time to mess around with this mouse. Legacy support IS enabled for usb 3.0, everything else about the mouse works, except the software wont recognize it on my g75, but will recognize it on my g74/g73/alienware desktop. which leads me to beleive that the razer software has a problem with usb 3.0. to the question about 64 bit software, razer only offers 32 bit.

I guess i am just going to use this mouse on my desktop, and save up for another naga, the 2012 corded model. in the meantime, all i want the software for is to remap the mouse buttons. is there some other software/way i can do that for my naga epic untill i get the naga 2012?

Also; one other strange thing... my older razer naga mouse, works fine on my g75, w/ the software and everything(which is why i know the naga 2012 will work). i just like how the naga epic and naga 2012 fit in my hand.

finalhour
06-16-2012, 04:20 PM
I'm having several issues with the USB 3.0 ports connecting to a USB 3.0 external drive AND a usb 2.0 external drive. I think there's a serious problem with the drivers that ASUS is providing, please tell them if you're experiencing issues so they actually look into this

waynes26
06-17-2012, 04:38 AM
Hi, If i usu both USB's on the left side, one for an external drive and one for my wireless mouse, i do have trouble with the mouse. so i use the left side for the HD and a spare slot on the right side. Then ALL works fine.

kiba
06-17-2012, 11:01 PM
no, nothing like that, only one USB device is connected and that is the mouse.

theoracle09
07-16-2012, 11:32 PM
Hi all, I joined the forums just to reply to this post.

I myself have a brand new G75VW and a brand new Naga Epic and it worked for the last 4 days and this morning for another hour or so until it stopped. I installed Driver Manager (thank you google, you're useless) but it said something about a "USB Composite Device" not working properly. The only option to fix said problem was to "plug the device in." Of course the device is plugged in.

*Update 3 minutes later: He has the same laptop (bought right after me 4 days ago) and uses the Naga 2012 wired mouse and he took my Epic and plugged it into his laptop and it worked. So he took his 2012 wired mouse and plugged it into mine and the drivers for that mouse worked and installed automatically perfectly, everything worked. This was plugged into the top port on the left side with the Epic plugged into the bottom port on the left side, and they both worked controlling the mouse on the screen. Unplugged the Naga 2012 wired, and my Epic still works in wired and wireless modes. Everything pops up saying it works. I can also map the keys with the updated software on Razer's website. (Driver version 3.03.)

I don't understand the issue, maybe there's a disconnect with the USB 3.0 software from Asus, I'm not sure. But my Western Digital 3.0 passport works perfectly, so I don't believe it's the port itself. The mouse is also currently working like it did the last 4 days, but who knows if it'll magically stop working again. I hope this jerry-rigged solution helps anyone.

valkko
10-13-2012, 09:11 PM
Win 7 ultimate 64
Driver working on USB 3

Hi, I recently bought a razer lachesis 5600 and I was having the same issue. I downloaded and tried install - uninstall the following driver versions:

Lachesisi win 7 (compatible only) v 1.10
RazerLachesis5600_Driver_v2.00 (working on USB 3 win7 64 ultimate)
RazerLachesis5600_Driver_v2.01
RazerLachesis5600_Driver_v3.00

I tried upgrading the firmware version to 1.94 (most recent on Razer web page), just to find out the mouse of mine has the 2.03 firmware preinstalled. The curious thing is this version only shows up if you install a specific version of driver. As I said, i tried all versions and the only one it worked was the 2.00, not listed on the traditional Razer support page, but reachable if you google it.

Before the installation of 2.00, the mouse freezed in the middle of a game and I had to unpluged it an repluged it, on usb 2.0 either 3.0

The url is http://www.razersupport.com/index.php?_m=downloads&_a=viewdownload&downloaditemid=482&nav=0,76
I know Naga and lachesis are way different products, but this helped me and I hope help you.

My advice to you is searching for every version of your driver, not on razer page, but google.

bignazpwns
10-13-2012, 09:42 PM
I never had any issues with my Naga epic. Only that it would automatic launch the program for about a month then all of a sudden it wont so i have to launch it my self to get my keybindings set up.

wtfdaemon
09-11-2013, 03:29 PM
For both Razer Lachesis and Naga that I have - run the configurator as an Administrator via right-click context menu, and it'll find the mouse first try, guaranteed.

Drove me nuts till I figured that out,