PDA

View Full Version : Help to identify missing G55V drivers? (PCI-bus0/unit22 + PCI Slot1/PCI-bus3/unit0)



Boulderdash
06-10-2012, 10:51 AM
Hi everyone.

I recently bought an Asus G55V laptop. Since Asus insists "enhancing" Windows 7 with quite a bit of bloatware, I decided to make a clean install using my old Windows 7 Professional product key. The installation worked flawlessly (I'm using Windows 7 Professional x64 with SP 1, fully patched). However, the Windows Device Manager is unable to identify a couple of hardware devices. Hopefully though, you guys can help me telling out.

The first unknown device is said to be a "Network Interface Unit" (in translation from Swedish, I'm not sure what the English version of Windows would call it). Upon closer inspection, this device is located on "PCI-bus 0, unit 22, function 0".

The second unknown device is said to be a "PCI interface for simple communication" (again, I unfortunatly don't know the proper English translation since I'm running Windows in Swedish). According to the Device Manager, this particular device resides in "PCI Slot 1 (PCI-bus 3, unit 0, function 0)"

In both cases, the Device Manager says that the drivers for both devices are missing. Now, I have tried to install both drivers from the Driver & Utility Ver 2.0. disc, however Windows can't find any drivers for either device on the disc. For reference, Please have a look at the following screenshot to see what the Windows Device Manager looks like on my G55V:

http://i.imgur.com/jLinb.png

If anyone here would be kind enough to tell me what the devices on "PCI-bus 0, unit 22, function 0" and "PCI Slot 1 (PCI-bus 3, unit 0, function 0)" are supposed to be and where I can find the drivers, I'd very much appreciate it! Thank you in advance! :)

waynes26
06-10-2012, 11:49 AM
I found ths on my G75 maybe a clue. For one of them. I will keep looking for the other one

9172

waynes26
06-10-2012, 12:03 PM
Here they both are sorry for uploading in Paint. Try loading for your util disk. Intel Management Engine Components and the wireless driver.;)

9173

Boulderdash
06-10-2012, 02:03 PM
Here they both are sorry for uploading in Paint. Try loading for your util disk. Intel Management Engine Components and the wireless driver.;)

Spot on, Wayne! Thank you so much! With your help, I managed to track down the missing drivers and get rid of those pesky, yellow warning signs. I doubt I could have done it without you! (also, thank you for taking the time to grab that screenshot as well!) :)

For the record (in case anyone else is in my situation), the driver packages/ZIP-files you are looking for to resolve this problem are the following (please note that new driver revisions may be released by the time this post is being read, and that the file names may differ):


MEI_Intel_Win7_64_Z8031427.zip (the "Intel Management Engine Components") WLAN_Atheros_Win7_64_Z920469.zip (the "Atheros AR9485WB-EG Wireless Network Adapter")

Both files should be available to download from the Asus support site.