PDA

View Full Version : New (refurb) G74 only works when plugged in



emers098
06-13-2012, 10:21 PM
This issue has only been occurring the past week or so. The battery power is fully charged right now and if I unplug my power connector, the computer will immediately shut down. If the computer is off (and the battery fully charged or at any level), it will not turn on unless the power connector is plugged in. I am hoping that there is just some settings that got messed up and its not the hardware. Please let me know if anyone has any ideas.

Thx1138
06-13-2012, 10:23 PM
That's a battery problem. Do you have the option to take the computer back?

jd2266
06-13-2012, 11:16 PM
you can download a program called speccy.it is free,when you run it it will show the wear level of the battery,if the battery is fully charged and speccy shows a very high wear level i would assume you need a new battery

brecker
06-13-2012, 11:21 PM
your battery is probably dead...

emers098
06-14-2012, 01:06 AM
I'll try speccy. I apparently have a 90 day warranty with ASUS so I'm setting up to return the battery for testing.

emers098
06-14-2012, 03:21 AM
I just unplugged the power and it ran normally down watching a movie for about an hour before I shut it off. Everything seems normal. This was after I took the battery out and put it back in. Either that I'd something or it's only happening some of the time. Maybe the battery was just loose?

dstrakele
06-14-2012, 05:27 AM
Does the battery fit snugly in its bay? If it wiggles around, you could try to shim it in tighter with plastic film or Mylar.

Cheeeter53
06-16-2012, 08:08 PM
Maybe the contacts between the battery and the laptop are not aligned. Does the battery indicator light blink when the laptop is running on AC power? That tells you that you are running the laptop without a battery. If It blinks on battery it tells you that the power level is very low >10%.