View Full Version : FN Keys with Ubuntu 12.04

06-19-2012, 02:08 PM
Does someone know how to enable the FN keys with Ubuntu 12.04 ?
Or at least how to change the brightness ?

06-20-2012, 08:00 PM
For brightness control, I found that http://askubuntu.com/questions/126441/brightness-controls-doesnt-work-on-a-macbook-pro-5-5-ubuntu-12-04-lts

But I couldn't find anything for the other fn keys. They are not even recognized by xev nor keymap so I think there is no hope there... I'm starting to regret my tower :mad:

06-20-2012, 08:17 PM
The FN keys are software supported on Windows via the ATK package. I'm not sure how you'd do it.

06-21-2012, 09:54 PM
thanks for your reply.
i actually have a dual boot and all features are working under windows.
but under ubuntu that's quite another story... a collegue of mine told me today that asus laptops are known to have a bad linux support, or the other way around for some cases. so i should have checked before, that's on me :(

08-25-2012, 06:24 AM
All the Fn keys work under Ubuntu 12.10 alpha 3 as of this writing. Well, minus the screen brightness. However, screen brightness is supported by Ubuntu (worked on my MacBook Pro, and my Dell XPS) and I am sure that a driver update will fix this.

08-26-2012, 03:17 PM
rrohde, iv been toying with 12.10 this weekend. Are you able to get somewhat uncrashing Compiz+unity?. im on the properity drivers, not noevaue. Noevaue does accually get me logged in but everything crashes almost instantly.

sorry for hijack.

08-26-2012, 08:31 PM
rrohde, iv been toying with 12.10 this weekend. Are you able to get somewhat uncrashing Compiz+unity?. im on the properity drivers, not noevaue. Noevaue does accually get me logged in but everything crashes almost instantly.

sorry for hijack.

Now that's the big issue I am facing right now as well. On my Dell XPS,which runs NVDIA Optimus with an Intel video card, 12.10 and Unity worked like a charm. The G75 not so much. I am, like you, now on Nouveau and it is slow and crashes a lot. Thanks to Xorg Edgers PPA I was able to install nvidia-current, but Xorg keeps crashing with segmentation faults all the time.

The only thing that does work for me currently is Classic Gnome w/o effects, which will be installed along Gnome Shell.

I am sure that they will fix these issues down the line, but for now the only option is to a) install Xorg Edgers PPA, b) install nvidia-current next, and c) be content with Gnome Classic w/o effects.

At least then you get your Fn keys (minus brightness for now). :)

08-28-2012, 09:43 PM
Finally got my usb stick so i could do a proper install and not a net install. Anyway iv gotten things relativly stable and working.

What i did was install XuBuntu 12.10-desktop (says its 12.04 in the installation but its not). then ran update-manager from a terminal, exit out to console, sudo service lightdm stop. and then sudo sh NVIDIA-Linux-x86_64-304.43.run, go through the steps, it will disable novaue for you and then say it failed. reboot, exit to console, sudo service lightdm stop, and run NVIDIA-Linux-x86_64-304.43 again.

You will probobly be missing the nvidia tool entrys in the menus and stuff but not realy that important. anyway after that i hit software center (it crashes directly if i installed regular ubuntu with unity) and install ubuntu desktop (unity) from there. it will tell you about some minor conflicts i just accepted the resolve and then reboot and select ubuntu on login.

Will be testings from here. sofar so good.

08-28-2012, 11:05 PM
Aaron Plattner of NVIDIA just announced that the Xorg/NVIDIA bug that caused segfaults when launching Unity was fixed with nvidia-current 304.43 drivers.

I tested it in 12.10 alpha 3 and everything works like a charm now!

08-28-2012, 11:08 PM
awsomesauce, i guess i was just lucky then :) n1

08-28-2012, 11:12 PM
... the good thing is that those drivers are straight from the repos. No need for workarounds anymore. :o ...still no brightness via Fn though.

08-29-2012, 08:22 PM
mm id like to have my media keys aswell, there activated via fn keys on my kboard. fn+f1-f6. apperenrly in windows they are supported via some atk something package. Guess it could be reversed.

08-29-2012, 08:43 PM
Well, the media keys all work in the current Ubuntu 12.10 alpha, except for:

- Brightness (guess that's an nvidiabl issue and should be fixed soon)
- Fn+V (for the camera software; however, the camera works great in Ubuntu with Skype or Cheese)
- Fn+Space (change power presets)

The other Fn keys work like a charm. :)

09-02-2012, 04:58 PM
Ok guys so as of this morning I have all of my function keys working on Ubuntu 12.04 including LCD brightness.
I did this by using the following packages and tinkering until it started working.
I used the asus-WMI-999.01 package as laid out
HERE (http://forum.notebookreview.com/asus-gaming-notebook-forum/553474-g73-asus-wmi-linux-driver-i-need-your-help.html)
Next I used Nvidiabl which can be found
HERE (https://github.com/guillaumezin/nvidiabl)
Finally I followed the Instructions listed
HERE (http://askubuntu.com/questions/126441/brightness-controls-doesnt-work-on-a-macbook-pro-5-5-ubuntu-12-04-lts)
regarding modifying Xorg.conf

It took SEVERAL hours of tinkering to get it working. But as of this morning everything is working. I wouldn't bother asking me a bunch of questions as to how I made it work. Honestly I don't remember, I spent most of yesterday and this morning working on the back-light issue and building a functional GRUB2 UEFI configuration. Which by the way is easy, Install your Ubuntu install then run update-grub, and modify the grub.conf file by:

Chainloading Windows x86_64 UEFI-GPT

Find the UUID of the FAT32 filesystem in the UEFI SYSTEM PARTITION where the Windows UEFI Bootloader files reside. For example, if Windows bootmgfw.efi exists at /boot/efi/efi/Microsoft/Boot/bootmgfw.efi (ignore the upper-lower case differences since that is immaterial in FAT fs):

# grub-probe --target=fs_uuid /boot/efi/efi/Microsoft/Boot/bootmgfw.efi
Then, add this code to grub.cfg to chainload Windows x86_64 (Vista SP1+, 7 or 8) installed in UEFI-GPT mode :

menuentry "Windows x86_64 UEFI-GPT" {
search --fs-uuid --no-floppy --set=root 1ce5-7f28
chainloader (${root})/efi/Microsoft/Boot/bootmgfw.efi

Again, lots of poking and prodding to get this working just right, however this was the key that finally did the job for me. I hope this info helps others.

By the way in case it matters I am running a g75vw with windows ultimate/Ubuntu 12.04 dual boot.

09-02-2012, 07:18 PM
Excellent write-up, RcCypher. Thanks. :)

03-16-2013, 12:14 PM
how can i play Assassin's Creed on ubuntu 12.04 (i use bumblebee)