View Full Version : G74SX-ST1: Two obscure issues

06-19-2012, 07:25 PM
So I'm hoping someone in the community here has some ideas about what might be occurring with two seperate (and very annoying) issues I'm having with my G74SX-ST1:

1) My blu-ray drive will NOT read any media other than blu-ray discs UNTIL I put in a blu-ray disc. So basically, it will not read any CD-ROMs, DVDs, etc, until I play a blu-ray disc. After that, it reads any disc fine until I reboot. I should note that I dumped the default blu-ray player in favor of Cyberlink's PowerDVD 11.

2) Periodically, and without warning, my G74S will start acting odd, then blue screen. When I reboot the laptop, it doesn't recognize my boot sector OCZ Agility 3 SSD I have installed as the boot drive. After completely powering the system down and then starting it back up, I can then go into the bios and it recognizes the drive again, at which point I have to set it as the boot drive again.

I'm hoping that both of these are simple settings issues, and I strongly suspect that it is a software issue and not a hardware one. Any help or ideas with either of these issues would be greatly appreciated!

06-19-2012, 08:01 PM
Have you checked to see if there is a newer firmware for the SSD? Older OCZ firmware has had problems. No idea on the optical, sorry.

06-19-2012, 08:04 PM
Thanks for the suggestion, xeromist. I'll check OCZ's site for a firmware update tonight.

06-19-2012, 08:17 PM
before i got my hyper x i did some research and i did read that people were having problems with OCZ ssd's with old and new firmware so if u still can i would return it and get something different , Intel is pretty reliable but pricey , about the OD try cleaning it with some compress air they get pretty dusty .

06-19-2012, 08:57 PM
It can't be an issue with a dirty optical drive, because it reads other discs immediately after I insert a blu-ray disc. I'm convinced that this is some sort of software setting or conflict, but I can't identify what that is on my own.

06-19-2012, 09:17 PM
Try reinstall your Blu-ray drive drivers. Enter to "Device manager" select your drive, uninstall drivers and wait till windows automatically detect new device or restart laptop.

06-19-2012, 10:02 PM
It can't be an issue with a dirty optical drive, because it reads other discs immediately after I insert a blu-ray disc. I'm convinced that this is some sort of software setting or conflict, but I can't identify what that is on my own. i know but i think that cleaning it could help , also try uninstalling and installing the drivers again and if all fails a clean windows install is the best way to go.

06-20-2012, 02:31 AM
Uninstalled the drivers, rebooted, then Windows reinstalled it. Same BD-ROM behavior... :(

06-20-2012, 02:00 PM
So I've yet to upgrade the firmware on my SSD, because per OCZ, you can't upgrade the firmware via their utility on a primary drive. Once I'm able to do this using another PC, I'll report back results on this thread.

I'd still appreciate other thoughts and ideas on the BD-ROM issue. Can this possibly be some kind of registry setting or program conflict?

06-20-2012, 03:50 PM
Registry, doubt it.
I would try going back to the default player and see if you can reproduce the error there.

06-20-2012, 04:05 PM
This problem occurred with the default player, which is what prompted me to install and test with new player software.

06-20-2012, 04:12 PM
If it's BSODing, it's probably creating a minidump file. Have you tried debugging it to see what the cause is? Also, have you checked the event viewer to see if there are any issues in there showing up?

If I am correct, BD Drives have 2 lenses in them; One for BluRay and another for the DVD/CDs. It could be that the drive is having a hard time initializing the arm for the DVD/CD lens, which could lead to a bad drive. Have you tried switching to a different SATA port? Make sure your BIOS is up to date, along with various chipset drivers?

06-20-2012, 04:14 PM
if its been happening since you got it with the default player it looks like its a hardware related problem and not just software.

06-20-2012, 05:08 PM
I haven't tried checking the dump file yet, so I'll do that tonight. I'll do the same with event viewer.

I'm hoping this isn't a physical problem with the drive, but I suppose it very well could be the case. I'll probably contact ASUS support on this issue and see what they say.

09-04-2012, 12:39 PM
I just wanted to follow up on this thread for those interested.

On the first issue with the blu-ray drive, the issue was resolved after I did a clean installation with an ISO image of Win 7 Home Premium (and NOT the factory restore), and installed TotalMedia Theater 5 for BD-ROM playback.

For the second issue, I'm fairly certain that a firmware update will resolve the issues with intermittent, random, crashes of the SSD, but I will note that since the Windows reinstall, I've not experienced any issues. Yet.

Hope this information helps someone out there!