View Full Version : G73SW Integrated Microphone Issue (& external it seems now, as well)

06-22-2012, 11:13 PM
Hello all!

I'm an Asus G73SW owner, and ever since I got it I have been experiencing very annoying issues with my integrated microphone. This is especially annoying due to the fact that I need to record myself a lot, both for programming tutorials, but also because I'm a soon-to-be classical/opera performer, and would like to be able to record myself on the laptop. My iPhone is an option, but it would be so much easier to be able to upload it straight from my computer. Not to mention Ventrilo & Teamspeak whenever needed.

Having said that, whenever I record myself, there is a lot of feedback with overlapping frequencies that get higher and higher, up until the point where it hurts my ears (in the sense of echo mostly, especially when I also play music in the background - it vanishes for two seconds sometimes and then comes back with an echo tenfold).

So, what I tried was to enable all the extras in the sound panel, such as echo cancellation, turning decibel boost all the way down, etc. all to no avail. After that, I tried to uninstall and reinstall my Realtek drivers, but that didn't do the job either.

At last, I went to buy an external microphone yesterday, but the very same issues occur (only sometimes a bit less "heavy").

Any idea as to what might be the cause and how to fix this? I would greatly appreciate it.


07-02-2012, 12:54 AM
Sorry for bumping.

Anyone who happens to have a clue?

Thanks. :)

07-02-2012, 03:17 AM
Sounds like your microphone has the "listen" option on. That practically guarantees feedback.

Right click on the speaker icon in the system tray, select "Recording Devices".
Double-click on one of the microphones you use.
Click the "Listen" tab and Un-check the "listen" box.
Click "Apply"

Do this individually for all the microphones you use.

Hope this helps!

07-02-2012, 06:05 AM
Hey there and thanks for your reply.

Unfortunately this doesn't seem to be the issue. It has no "listening" enabled at all. The same issues mentioned above occur even if I try and use headphones.

07-02-2012, 07:44 AM
If it even happens with headphones, maybe the 'Stereo Mix' recording input is feeding back.
Try the above instructions and instead of microphones, double click on "Stereo Mix" if its enabled. I believe Stereo Mix is disabled by default, but it's worth a look.

If there's no Listen tab there either, go to the "Levels" tab and lower it to zero just to be sure.

Only other thing I can suggest would be lowering all output device volume controls to zero while recording.

Good luck.