PDA

View Full Version : Asus G75 screen flicker (dark backgrounds and low brightness)



Rayearth
06-27-2012, 06:42 PM
Hi,

I bought today the Asus G75VW and noticed the same problem that occurs in the previous gaming series G74.
The screen still flicks more or less when displaying dark background and the brightness is set to lower than maximum.

In the thread below concerning the same problem in G74 laptop series I found a solution which apparently is confirmed to work in many other Asus laptops. In short, what I need to do is to disable the Intel DPST (Display Power Saving Technology) in the power savings plan supplied by the Asus Power4Gear Hybrid software.

Unfortunately this option is not present under the section Asus P4G Power Setting in my power plan. There's only "Hide Gadget" and "Battery Saving Desktop". I already tried to remove the factory Asus Power4Gear Hybrid and install the version from Asus Support, but still this option isn't there.

Do any1 of you have it in his power settings plan on G75 series laptop? How can I make it appear in my settings?


http://rog.asus.com/forum/showthread.php?5536-Asus-G74-screen-flicker-(dark-backgrounds-and-low-brightness)&p=40420&viewfull=1#post40420

MPelissari
06-27-2012, 07:17 PM
I had that issue too in my G75, but since my fresh windows installation, i haven't install the Power4Gear Hybrid Software at all since i use some difirent options on the high performance profile, and everytime that i did a single change after the reboot it keeps saying that it had to change it back to default settings... so now that i don't have it installed... no problem at all...

Rayearth
06-28-2012, 09:07 AM
But do you encounter screen flicks after clean Windows installation and without Power4Gear Hybrid Software?

dstrakele
06-28-2012, 09:42 AM
1) The latest NVIDIA 304.48 BETA driver has resolved the "flickering horizontal lines" issue for several users.

2) Creating an NVIDIA Custom Resolution with a Refresh Rate of 67 Hz or 75 Hz in the NVIDIA Control Panel as discussed by @ny2lond has resolved this issue for others. See http://rog.asus.com/forum/showthread.php?5536-Asus-G74-screen-flicker-(dark-backgrounds-and-low-brightness)&p=108570&viewfull=1#post108570 for details.

Rayearth
06-28-2012, 11:16 AM
1) The latest NVIDIA 304.48 BETA driver has resolved the "flickering horizontal lines" issue for several users.

2) Creating an NVIDIA Custom Resolution with a Refresh Rate of 67 Hz or 75 Hz in the NVIDIA Control Panel as discussed by @ny2lond has resolved this issue for others. See http://rog.asus.com/forum/showthread.php?5536-Asus-G74-screen-flicker-(dark-backgrounds-and-low-brightness)&p=108570&viewfull=1#post108570 (http://rog.asus.com/forum/showthread.php?5536-Asus-G74-screen-flicker-%28dark-backgrounds-and-low-brightness%29&p=108570&viewfull=1#post108570) for details.

Thanks, will try this at home.

Bundy_Drop_Bear
07-06-2012, 11:21 AM
I just this laptop today, and I now have this flickering problem, I tried all the suggestions in here and in the G74 flickering Post, none of them worked, I found that if I lower the screen MHz from 120mhz to 60mhz that the flickering seems to disappear from desktop. However I tried out a game "just Cause 2" and the screen flickering started happening there too. I installed the lastest Nvidia beta 301.48 drivers and it didn't help.

If anyone has further suggestion on how to remove this problem pleas post it.

waynes26
07-10-2012, 01:40 PM
I just this laptop today, and I now have this flickering problem, I tried all the suggestions in here and in the G74 flickering Post, none of them worked, I found that if I lower the screen MHz from 120mhz to 60mhz that the flickering seems to disappear from desktop. However I tried out a game "just Cause 2" and the screen flickering started happening there too. I installed the lastest Nvidia beta 301.48 drivers and it didn't help.

If anyone has further suggestion on how to remove this problem pleas post it.

Hi I'm running the exact machine as you have all be it i changed the primary drive to an SSD. My screen is Ok, but I'm running 304.79 Beta.

Destroyer99
07-10-2012, 02:48 PM
Hi I'm running the exact machine as you have all be it i changed the primary drive to an SSD. My screen is Ok, but I'm running 304.79 Beta.

If you look in the topic posted above on solution keep reading it down a post or 2. The solution there works,. i had a flicker problem too but it worked after the adjustments.

da_nikon
02-15-2013, 07:26 AM
Sorry for digging this old thread, but i have a problem.


I'm a owner or G75VX since Monday. My panel is CMO1720 and i am experiencing the screen flickering issue. I have tried the custom refresh rate of 67Hz but with no/very little effect. I have tried also to max the brightness from the button combo and then to manipulate the picture from nVidia panel (brightness + contrast) but still getting flickering.

Please G75 owners, help me! The worse flickering i see is on this website http://livescore.com


Is there any recent nvidia drivers that fix this flickering issue or some new workaround this very annoying problem? :(


im using latest nvidia drivers from nvidia website with modded ini file. 310.90 (and im on windows 7 64bit)

gokica
02-15-2013, 07:57 AM
http://rog.asus.com/forum/showthread.php?28621-G75VX-screen-flickering&highlight=flicker

No help I am afraid.

da_nikon
02-15-2013, 08:15 AM
@gokica thank you. I guess i will have to buy external monitor to workaround this issue. Or maybe if they enable Optimus soon it will fix the issue. :(

This is so unfair.. 1400 euro laptop with 50$ screen :(

gokica
02-15-2013, 08:29 AM
I doubt that Optimus will resolve the issue. It is the screen that has problems.

Tomislav
02-15-2013, 08:40 AM
I haven't had this problem...my screen is OK. but as I said it just OK.

gokica
02-15-2013, 08:42 AM
I haven't had this problem...my screen is OK. but as I said it just OK.

Which is your laptop's panel manufacturer and model?

da_nikon
02-16-2013, 03:57 PM
Hm.. i have managed to stop the flickering on latest beta 313.96 by setting the color to 16bit. But that reflects on the picture quality :(

gokica
02-16-2013, 07:09 PM
Yes color depth or lowering the resolution eliminates flicker but what good is it for us. :D

da_nikon
02-18-2013, 10:45 AM
Is it possible somehow to set color depth to 24 bits? Maybe that way the picture quality will be good enough and the flickering will be gone?

My options in nVidia panel are only 16 and 32 bits.

slayer2333
03-02-2013, 02:22 AM
The working solution for me was to create a custom resoltuion and replace the Automatic Standard Timing by CVT Reduced Blank. No change in image quality and no more flickering. Give it a shot.

gokica
03-02-2013, 12:27 PM
The working solution for me was to create a custom resoltuion and replace the Automatic Standard Timing by CVT Reduced Blank. No change in image quality and no more flickering. Give it a shot.

Can you please explain the custom resolution and the Automatic Standard Timing by CVT Reduced Blank procedure. Is it increase in HZ from 60 to 67 or something else is involved. Thanks.

slayer2333
03-02-2013, 02:34 PM
No increase in refresh rate, just go to nvidia control panel, change resolution, custom resolution, create custom resolution. In the new windows at the lower section (timing) replace the 'standard : automatic' by 'standard : CVT Reduced blank'. Test it and use it as actual resolution.
Thats it.

gokica
03-02-2013, 02:49 PM
Thanks. It does not work for me (G75VX AUO panel). It has bad effect. I got a bright white screen and nothing on it. It could not revert back. The only thing that saved me was to enable low resolution in the startup options so now everything is fine (the flicker is still here of course).

ny2lond
07-03-2013, 09:25 PM
Thanks. It does not work for me (G75VX AUO panel). It has bad effect. I got a bright white screen and nothing on it. It could not revert back. The only thing that saved me was to enable low resolution in the startup options so now everything is fine (the flicker is still here of course).

The problem is the same as with G74 series. I am very sorry for the late reply but I didn't visit the forum for almost an year.

"Open Nvidia Control Panel ->Adjust desktop size and position and select full screen.

Next, go to change resolution -> Customize -> Create Custom resolution -> Type 67 in refresh rate. Make sure Scan type is set to Progressive and hit test. If all works well, select yes.

* * * After this, there should be a Custom with you creation, above PC list. Select it, press the drop-down list and select 67 Hz with 32-bit Colour depth and hit apply.

If creating the custom resolution doesn't work (ex: it tells you it is not supported) type 132, select Interlace and hit test. Whatever happens (mine did some weird display glitches and I unplugged the laptop... scared me like s**t) just hit Esc.

If nothing works, just type 33 Hz, Select Progressive and hit test, it should work. If it does, select no and then type again 67 (probably some driver bugs).

Whatever way you manage to create that 67Hz, always do the "* * *" part

Here is a site to test it, because of the background (It's the one that made me do all these tests): http://www.3dtotal.com/index_gallery...s#.T7z1_EUnxkw

The Brightness LED's work in a frequency multiple of somewhere around 67Hz. As the display has a 60 Hz refresh rate, that makes a 7 Hz offset, which creates the flickering. It's like in sound - the resonance effect.
Another cause for the flicker is the crosstalk effect. On certain patterns it will also flicker, but this has nothing to do with the refresh rate.

Hope I am not too late :-S

ny2lond
07-04-2013, 09:24 PM
type 91, not 65
After more testing, the frequency that does the trick is the 91Hz one...

twisteddiana
11-19-2014, 08:24 PM
Thank you, ny2lond, followed your instructions (although the 67 did no good for me, 70hz did) and now I'm seeing less flickering.