PDA

View Full Version : Asus K52JT - Web Cam problem



Skedenj
03-05-2011, 06:59 PM
Hey

I've been having Asus K52JT for some time now and the webcam has always worked well. In the last week it started behaving strangely. I have to restart every time i want to have a video chat otherwise the other party doesn't see me. Sometimes even that doesn't help, but the next restart usually sorts things out.
At the same time i got reports from skype that i should close down other programs that might be using the camera which is not working apparently for that reason. I then deleted "Asus Virtual camera" from my laptop and the problem disappeared. At the same time, when i desperately tried to solve this problem i also uninstantiated the drivers for the in-built webcam, thinking i will install new ones which i found on Asus website. But i had a nasty surprise when i tried to do so. For my computer there rare 3 different drivers available.
Azurewave Camera Driver
D-MAX Camera Driver
Chicony Camera Driver

It doesn't matter which of them i try to install - i always get upon clicking the installation exe file the same window "VGA, 1.4, 2.0 WebCam - error".
The driver i previously uneinstalled was from Chicony if i remember correctly.

Now comes the funny bit. If i go to the Device Manager i can see just "USB Camera" with Windows driver which inverts the whole picture upside down!

Also, the "usb Camera" for some reason disappears after a variable amount of time. At that point also in skype it appears the computer doesn't have a webcam. I must also say that the webcam has actually never stopped working while in use in a video chat. :(

Please, help me. I really don't know what else to do. :(

Skedenj
03-06-2011, 07:30 AM
Update:

I have restored windows to an earlier date. I again have the original driver installed which is from a company called "Sonix".

The problem that is still present is that the webcam suddenly disappears from the Device manager and the laptop needs to be restarted in order for the webcam to appear again. It can also happen that the camera is used for a video chat and then, after a few minutes when i want to use it again, it's not there anymore.

What could be the reason? I have updated the existing driver trough device manager (clicked update driver), but windows reported no new drivers for this device... What else can i do? :(

Thanks so much for your help.