View Full Version : For anyone having WIFI connection issues on their G75 or G55, look here.

06-29-2012, 03:02 AM
I've seen numerous posts on people complaining that their wireless connection is either dropping every few minutes, or is really slow, or just doesn't connect to the driver.

Downloading these drivers :


solved it for me.

07-01-2012, 12:36 PM
Sadly I still have the can't connect isssue

07-01-2012, 01:00 PM
What have you tried to resolve your issue to date?

07-01-2012, 01:14 PM
i tried a plethora of driver currently running the currert one from asus and any time i try to connec i get the couldn't get internet

07-01-2012, 01:46 PM
Oh that's good! I'm supposed to use "plethora" in a sentence today... Here's my plethora of troubleshooting questions:

1) What model ASUS laptop do you own?

2) What make and model WiFi card is installed?

3) What version WiFi driver are you currently running?

4) What make and model WiFi Router do you have?

5) What channel is the router configured to use?

6) What a) Security and b) Encryption have you configured for the Router? What Security and Encryption have you configured in your Windows wireless network? I'm using WPA2-Personal Security with AES Encryption - works well for most wireless networks.

7) Does the wireless icon in the Windows System Tray show a strong signal?

8) Do you have any other computers that successfully connect to your Router?

9) Have you reset your modem and router?

07-01-2012, 02:38 PM
It is a g75 i baught from a local shop
The wifi card is an Athereos ar9485wb-eg
The wifi im connecting to is a wpa2-psk 802.11n wifi network on wich i have several other devices on wifi and on ethernet namely my desktop pc on ethernet and my macbook pro on wifi driver version is apparently downloaded from assus page wifi is on channel 1 an i have a 4 bar good signal strength. So that was my "plethora" of answers.

07-01-2012, 03:32 PM
1) What Encryption is configured in your Router and in Windows?

2) What make and model Router are you using? Is it 2.4 Ghz, 5.0 GHz, or both? Are you attempting to connect to N protocol on the 2.4 ghz band?

3) Does your Atheros Wireless Network Adapter show it is functioning normally in Device Manager (i.e. no exclamation point in yellow circle)? In Properties for this device, is it configured in Wireless Connection Mode for b/g, n only, or Auto?

4) If so, is the Wireless Radio in your laptop turned on (Fn-F2)?

5) Have you deleted and recreated your Windows Wireless Network?

6) Are there any Errors or Warnings that reference networking in your Windows System Event Log?

7) What is displayed in the Router Log when you attempt to connect?

07-01-2012, 04:05 PM
Wpa2 psk is the encryption it is a 2.4 band ani am trying to connect to the n protocol device manager has no errors nor do i have any error log refering to wifi No wireless radio, i havent tried to delete the network (how does one do that?)
Router log shows no attempts of connection.... I see no option for band selection though

07-01-2012, 05:05 PM
When you press Fn-F2 on a G74SX , it cycles between WiFi On, Bluetooth On, WiFi Off, Bluetooth Off, with cute little animations displayed on the screen. When you post "No WiFi Radio" do you mean your G75 does not display this behavior when you press Fn-F2? If not, you may need to repair or re-install the ATK Package.

I'd like you to confirm your laptop's Wireless Radio is ON. The lack of any connection attempts in the Router Log would appear to indicate the Wireless Radio is off.

07-01-2012, 07:00 PM
All connections are on due to a mistype i may have seemed stupid i meant that no the fn+f2 is not turned off.

07-01-2012, 08:54 PM
Then let's try deleting the current Wireless Network and recreating it. Click on "Start" and in the searchbox enter "manage wireless networks". On the right side of the resulting Dialog, choose "change wireless network order". Right-click on the problem network and choose "Remove" from the popup menu. Then display the available wireless networks by right-clicking on the wireless hetwork icon in the System Tray. Select your Router SSID, enter the correct password and see if you connect. If not, report the exact error text.

07-02-2012, 06:08 AM
I get the same message as usual windows was unable to connect to the network...

Addendum upon setting the routers band to g it works but seriously limits the wirless speed... Shouldnt this laptop support n?

addendum 2 after unmixing the bands and setting it to n i do indeed get connected so it appears that athereos
cards hate mixed bands...