PDA

View Full Version : Asus G75 Subwoofer not working



jdotjdot7
06-29-2012, 06:11 AM
I recently noticed that my subwoofer is no longer functioning, not that big of a deal considering when it did work, i remember it screwing up the audio but still I would like to be able to use it if I find a way to add a Low Pass Filter on it in the future. Any ideas?

kiba
06-29-2012, 01:17 PM
do you have the VIA audio driver installed? without it, the sub wont work, if it IS installed... download the 10400 driver from asus support, uninstall your current driver, restart, then install the new driver. you can use a driver sweeper if you want.

post back here w/ your results.

jdotjdot7
06-29-2012, 02:59 PM
Actually, I was doing just that last night after I posted this thread and it didn't make a difference. I can test the speakers in the configure menu and the subwoofer wont make a noise. I am going to be plugging this thing into my Insignia speakers with a subwoofer anyways in the future but still, it kind of irks me that the subwoofer isn't working. Even moreso if its a defect.

MPelissari
06-29-2012, 03:14 PM
That is new, some people have tried the new beta driver to fix the audio problems, on my i use the 10400 i can have the sub working normal, only when i'm into something like a game or movie using the headphones that i have to unplug and plug again for the sub to cut the sound... try to plug and unplug or do a fresh install of the driver to see if helps...

john_from_ohio
06-29-2012, 04:57 PM
I recently noticed that my subwoofer is no longer functioning, not that big of a deal considering when it did work, i remember it screwing up the audio but still I would like to be able to use it if I find a way to add a Low Pass Filter on it in the future. Any ideas?

The "subwoofer" ( aka central speaker ) only is used if the 2.1 channels selection is in effect.

Shot in the dark guess is that maybe you do not have that selected / turned on at the moment ... you can go into Via HD Autio Deck and into Expert Mode and check that the ( blue dot is turned on ) 2.1 channels is selected ...

jdotjdot7
06-30-2012, 05:57 AM
The "subwoofer" ( aka central speaker ) only is used if the 2.1 channels selection is in effect.

Shot in the dark guess is that maybe you do not have that selected / turned on at the moment ... you can go into Via HD Autio Deck and into Expert Mode and check that the ( blue dot is turned on ) 2.1 channels is selected ...

Mine only has Stereo and 5.1 and currently it is set at 5.1, the subwoofer makes no sound.

BrandeX
06-30-2012, 01:13 PM
the other properties menu, turn on 2.1

UsedBlueCray0n
06-30-2012, 02:46 PM
Could you please specify "other" properties menu? Because I see none and I can't change it from 5.1

BrandeX
07-03-2012, 05:03 AM
In the windows audio control panel. highlight the speaker, there is 2 button under it, one is like options, the other is properties.
I am not on my pc at home atm.

kiba
07-03-2012, 10:12 AM
^the two usually dont mesh well together. but yeah, john is right, you need 2.1 for that sub(aka center channel) to work.

Moises
12-22-2012, 04:55 PM
Few days ago i downloaded the hd Vdeck program and for some reason it did something to my sound drivers so i couldnt play any audio without headphones on, last night my laptop went thru a windows update and now i cant play audio at all, i try updating my drivers to the 10400 update but this crap pops up http://puu.sh/1DXu7/2a30d2002841ade8ec211d7fb1af447d

like seriously asus, its a software problem, cant you just release an update to fix this for all of us who pays OVER THIRTEEN HUNDRED DOLLARS AND UP TO TWENTYTHREE HUNDRED DOLLARS for your oh wow big piece of ass laptop?

GottiBoi55
12-22-2012, 05:36 PM
Could you please specify "other" properties menu? Because I see none and I can't change it from 5.1

What you need to do:

1. click on the "Start button" in the bottom left (W7)
1.2. (W8 open "charms" @ the right then step 2)
2. click on "Control Panel".
3. click on "Hardware and Sound".
4. click on "VIA HD Audio Deck" at the bottom.
5. click on "Expert Mode".
6. click on the"icon" that looks like speakers, will say "Speaker setting and test" when you hover over it.
7. click on the "2.1 channels dot", this should be "blue" when on.
8. click on the "blue button" under "Loudness EQ' to test.

You should have the function of the "sub", if all is well with the "drivers".

Moises
12-22-2012, 06:56 PM
and seriously where are you guys even getting this program? out of all the useless bloatware this laptop comes with it doesnt bring this program and the one i downloaded doesn't seem to open when i click it, can anyone link me to a download of this program? i can't even find it on the own VIA's website...

GottiBoi55
12-23-2012, 12:20 AM
and seriously where are you guys even getting this program? out of all the useless bloatware this laptop comes with it doesnt bring this program and the one i downloaded doesn't seem to open when i click it, can anyone link me to a download of this program? i can't even find it on the own VIA's website...



You will need to download the"VIA Driver" from>>> G75VW/download
(http://usa.asus.com/Notebooks/Gaming_Powerhouse/G75VW/#download) You have to select W7 as OS because Asus doesn't have the driver for W8 yet
This should work in W8

Pitcher@asus
12-25-2012, 03:02 AM
ASUS already provide VIA audio driver in support website for Win 7, ASUS use bundle driver in WIn 8, so, please try install newly driver first, if any please connect to ASUS service center.

shibby1444
04-16-2013, 09:09 PM
Posting this in case this hasn't been resolved (or it remains the first hit on google when searching "asus g75 subwoofer problem").

I solved my problem by increasing the LFE in "Volume Control" (in Via HD Audio Deck/Expert mode/Speaker), which for some reason was 0. I've no idea what I did to make it 0, since it worked fine until a couple of days ago. Must have been some crazy, top-secret key-combo or something :P