View Full Version : G75VW - New OS - Wifi Toggle

06-30-2012, 07:34 AM
I just got a new G75VW for work, and had to install Windows 7 Professional.
I have all my Window's updates and drivers fully installed.

However, when I go to toggle my wireless, it only disables the bluetooth, leaving the wifi on.
I only get "All On" and "All Off", which I believe my G73 had 4 toggles.
I wasn't sure which drivers to install for both, there was both Atheros & Intel drivers for the wifi/bluetooth.
Intel's auto-detect website said I have an Atheros wifi, so I went with Atheros on both.
I also have the ATK Package driver for the rest of my toggle keys.

Anyone have any suggestions?

06-30-2012, 02:23 PM
It behaves the same on my system (I have Win7 home). Anyway, I think the FN+F2 key only toggles "all on" and "all off". To get WiFi or Bluetooth by itself, you have to manually click on the little graphic that pops up when you hit the FN+F2 keys.

06-30-2012, 03:41 PM
I'll test that out, but the main issue is that the wifi doesn't toggle at all, it stays connected the entire time.
The bluetooth drops though, so I know the function is doing something.

07-04-2012, 04:40 AM
Anyone have their FN key toggling their WIFI?

07-04-2012, 08:44 AM
you need the ATKCPI package from asus found here http://dlcdnet.asus.com/pub/ASUS/nb/Drivers/ATKPackage/ATKPackage_Win7_64_Z100016.zip

07-04-2012, 08:46 AM
I've installed Windows 7 (64bit) from scratch and
- ATK package
- KB Filter
- Atheros AR9281_AR9285_AR9485 WLAN drivers
- just Microsoft generic Bluetooth drivers - don't know which are the correct drivers (intel or atheros) to install

and FN + F2 doesn't work at all - it shows up WLAN on/off symbol but doesn't do anything
(WLAN still activ and Bluetooth as well).
And the WLAN indicator light on the front of the laptop is turned of from beginning - it'll just switch on and off with FN+F2 (but it doesn't change the connectivity state at all - still permanent on).

07-06-2012, 08:50 AM
still an open issue on my side - anyone got a clue ?

07-07-2012, 03:19 AM
Just saying that when I got the laptop I desinstalled the small running app that was showing the bluetooth and wireless icon telling to myself: bah, dosen't need this...windows allready have built-in shortcut for that....seems I was wrong!!! for me since that day "f2" windows shortcut only turn on and off the laptop wifi indicator light...dosen't kick in or kick out the real wifi connection, For me it's not that bad..I just go and manualy activate/deacivate the wifi card manualy via windows options.

07-07-2012, 09:54 PM
for sure it works to deactivate manually but on a 2200 Euro Laptop it's quite frustrating to see such
idiotic things.
Had an G73JH before and it works out of the box by just installing the ATK stuff and the KB Filter so
that all hotkeys and lights working the way they're meant to work.

07-17-2012, 07:30 AM
I'm still stuck with it - reinstalling the whole stuff didn't help at all.

c'mon someone must have solved this :)

07-17-2012, 07:41 AM
install Wireless Console and Intel WiFi Wireless LAN Driver

07-17-2012, 10:28 AM
>> install Wireless Console and Intel WiFi Wireless LAN Driver

it's an atheros card attached to my G75VW

Shall i really install this software to make it work :
- Intel WiFi Wireless LAN Driver Version V15.0.1.1 (asus driver download page)
- Wireless Console ?? <- whats this and where can i find it ?

07-17-2012, 11:41 AM
it's under Utilities http://support.asus.com/download.aspx?SLanguage=en&p=3&s=388&m=G75VW&os=&hashedid=gkyI9iViQxXxueTd

let's you control Wi-Fi and Bluetooth thru simple two button on-screen interace. I have it installed and it works great. And for some reason i had to install Intel WI-Fi soft, even though i have Atheros

07-17-2012, 01:10 PM
Wireless console 3 did the job - no need for the intel WiFi stuff.

big thanks mate !

==== solved ==== closed =====

07-17-2012, 05:50 PM
==== solved ==== closed =====

Closing my thread, who do you think you are. ;)

I had installed the Atheros driver right after my Windows 7 installation, due to the lack of a wireless driver.
I just now installed the Wireless Console and the wireless/bluetooth toggle works like a champ.

Thanks for all the help guys!

07-17-2012, 05:57 PM
Closing my thread, who do you think you are. ;)

hehehe - thought you already dissapeared for not posting any more in this thread - no worries :)

But i'm glad that this worked for you as well