PDA

View Full Version : Brand New G75 - Won't turn on (or wake up)



Nibbler
06-30-2012, 04:23 PM
Hey everyone, I'm new to the forum and in need of some help.

I bought my G75 last night, everything was going perfectly, it was running everything I threw at it flawlessly, and then the whole sleep thing us humans need on a nightly basis came into play.

So I decided to let steam run over night by downloading some game, and went to bed.

I wake up to my mouse not being lit up, my screen is completely blank, all but three lights are on at the front of the laptop... and the power button doesn't actually do anything.

I've tried Fn+F1, nothing.

Taking the power cord out + removing the battery - plugging it back in without the battery, nothing.

All sorts of 5 sec holding down power button combinations, nothing.

Praying to specific deities while drinking magic nectar from a goblet, nothing.

I feel as if there's some fancy schmancy "Instant On" function working against me right now or something.

Could someone help me please?

Thank you infinitely in advance!

john_from_ohio
06-30-2012, 04:42 PM
Hey everyone, I'm new to the forum and in need of some help.

I bought my G75 last night, everything was going perfectly, it was running everything I threw at it flawlessly, and then the whole sleep thing us humans need on a nightly basis came into play.

So I decided to let steam run over night by downloading some game, and went to bed.

I wake up to my mouse not being lit up, my screen is completely blank, all but three lights are on at the front of the laptop... and the power button doesn't actually do anything.

I've tried Fn+F1, nothing.

Taking the power cord out + removing the battery - plugging it back in without the battery, nothing.

All sorts of 5 sec holding down power button combinations, nothing.

Praying to specific deities while drinking magic nectar from a goblet, nothing.

I feel as if there's some fancy schmancy "Instant On" function working against me right now or something.

Could someone help me please?

Thank you infinitely in advance!

This does not sound good ... out of the box Asus has in place a "live update" piece of software that may try to install a BIOS update while running under windows. Kinda sounds like possibly that tried to run overnight and possibly bricked your machine.

Have you taken a look here ( G75-G55-IMPORTANT-USEFUL-THREADS (http://rog.asus.com/forum/forumdisplay.php?149-G75-G55-IMPORTANT-amp-USEFUL-THREADS) ) ... may be too late for this machine but I have suggestions in the thread about "what to do first " ...

Where did you purchase it from and what is the return/exchange policy? If Best Buy then just exchange it and follow my suggestions next time about what to do first ...

Nibbler
06-30-2012, 08:47 PM
Thanks for the reply.

I actually called up the store I bought it from and asked if I could exchange it for a different one since I just purchased it last night. They agreed, and with no questions asked they gave me a new one.

What's funny is I noticed the power cord felt different this time, and I do believe there was a tie-wrap around the power cord plug, which I don't remember being there on the original laptop I had first.

I probably got a refurbished/repackaged one that still had issues lol.

Smh.

All seems to be well.

john_from_ohio
06-30-2012, 09:00 PM
All seems to be well.

Well good news on that but please look at my thread "first things to do" and at least immediately do 3 things:

1) uninstall the Asus live update before something really bad happens

2) update the Asus recovery utility and after updating to most recent get a set of Recovery DVDs

3) make sure you have some kind of solid combination antivirus/firewall in effect ... preferably get that setup at home or somewhere behind a working firewall before ever connecting to any wifi out in the open ...