PDA

View Full Version : G73JH ATI Driver Questions...



wil2bm
07-02-2012, 09:11 AM
Sorry if this has been asked before - searched briefly but hoping someone can help me out before I clear everything out again!

Have still been having problems with my laptop and decided to try the Throttlestop workaround and see if that clears up some of my issues. After clearing out my AMD/ATI drivers/software (Driver sweeper, tune up utilities, windows 7 manager) I installed the latest 12.6 drivers and set up ts on start up. I just now noticed my display driver is listed as ATI FirePro M7820. Never noticed that come up before - not sure what to do from here.

Also if I've reinstalled windows since doing the vbios flash should I reflash or no need?

bashti
08-14-2012, 09:40 PM
I have the same issue. Some suggestions, please? :(

(It should display radeon mobility 5870)

CyberCorsair
08-24-2012, 10:12 AM
Had the same thing this he fix was to de-install the drivers and the old ones seem to kick back in and give you the right drivers .. then Manually get the new ones and install after doing the de-install .. this give you clean install with the correct drivers .. I am still trying to get an answer to why i got the wrong install as I used the auto fine on ATI site to ID my card and if i need an update but yet the wrong drivers were downloaded and installed ..

CC

mstcobra
08-25-2012, 08:57 PM
I have gotten into the habit of modding the .inf files. Not a fan of my card showing up as 5800 series. I did notice that if I download the drivers from the CCC update function it does give me a driver where the hardware ID 68A0 is read as a firepro card. I'm not sure why this is the case. What I have been doing and what I recommend to do is download the drivers from Guru3D. Here is a link to the latest set I found to be great. http://forums.guru3d.com/showthread.php?t=365083

Notice here the 68A0 is linked to the correct card:

AMD68A0.2 = "ATI Mobility Radeon HD 5800 Series"

btw 12.8 is out but I am not a fan of it