PDA

View Full Version : Asus ROG Vulcan ANC Headset mic humming sound



Deadlock
07-03-2012, 12:02 PM
I am getting a very loud humming sound with the Vulcan headset which competes with my voice and makes it difficult for people to understand me.
This happens if the ANC is ON or OFF.
I think the quality of recorded voice sounds clear underneath the loud humming sound.
I have tried a different, much cheaper headset which has no issues in the exact same Jacks. My voice is clear and there is no humming sound on the cheap headset.

I have all my drivers up to date.

I think this is a issue with the headset and it may need replacement because the cheaper headset works fine in the same jacks.

I just wanted to see if anyone had any ideas why it is happening.

I love the Vulcan headset. It is superb in every other way, i would really like to get this fixed.

Thanks for any help

Deadlock
07-05-2012, 02:52 PM
Any ideas what this could be? Has anyone else got the problem?

ryan9298b2
07-25-2012, 05:52 AM
Same Problem, No Answer. I was reading around and someone mentioned something of a grounding loop using front panel connectors, but I am using the rear connectors attached directly to the Creative Sound Blaster X-Fi Titanium Champion Series.

Ternega
08-04-2012, 01:59 AM
Hi. I was faced with same (I presume) problem. Problem in my case was lack of grounding on my notebook adapter. After getting my hands on one with proper power cord problem was solved.Having one is good for overall notebook health aswell.

Deadlock
11-09-2012, 04:50 PM
I found the problem, and it has something to do with the ANC in the headset.

If you take out the battery out of the headset and put your finger on the spring that the battery touches, the humming sound disappears.

I cant figure out a way to get a long term solution so i'm gonna get a refund on this headset hopefully, i'm not sure how to go about getting a refund just yet.

burkissyou
12-30-2012, 01:54 PM
I found the problem, and it has something to do with the ANC in the headset.

If you take out the battery out of the headset and put your finger on the spring that the battery touches, the humming sound disappears.

I cant figure out a way to get a long term solution so i'm gonna get a refund on this headset hopefully, i'm not sure how to go about getting a refund just yet.

i too have the same problem, i contacted asus and they answered this as an hardware problem and suggested me to rma my headphones, have you come up with any other solution to this?