PDA

View Full Version : Can't get WLAN to stay enabled on new G74SX



jbunnelle
07-03-2012, 10:40 PM
(sorry for cross-posting, had wrong forum)

I'm so frustrated, been working on this for over a day now. I just got a new laptop and right out of the box, I could not connect to my WiFi. After verifying that the connection was still valid with my old laptop, I upgraded all of the Asus and Ath. card drivers. When booting, it seems to sometimes detect all local connections, including my own. Then, after about a minute, the connection dies and they start to vanish one by one, until I get the red X icon, with no connections showing at all. If I hit the hotkeys to check the signal, both the WLAN and Bluetooth icons are circled-slashed out. If I enable them, they seem to be fine. But if I go right back in and check, they are grayed out and disabled again. I've reimaged the laptop and still have the same problem. Any ideas?

P.S. I have done the Asus Live updates via my ethernet connection, but this does not resolve it.

dstrakele
07-04-2012, 01:47 AM
1) What is the full model# of your G74SX?

2) In Device Manager, what is the name of your Wireless Network device?

3) If you right-click on it and choose "Properties" from the popup menu, does it indicate it is enabled and functioning correctly?

4) In the "Drivers" tab, what version driver is installed?

5) In the Windows System Event Log, are there any Errors or Warnings referencing the network or the Wireless Network Adapter?

jbunnelle
07-04-2012, 02:07 AM
1. G74SX-DH71

2. Atheros AR9002WB-1NG #3

3. Yes, status is "This device is working properly"

4. 9.0.0.222 (but just did clean install and haven't grabbed the latest yet; but they had no impact when I used them earlier)

5. The only thing I see highlighted as a warning under th system section is an Event 4001, WLAN AutoConfig. Message under general says WLAN AutoConfig service has successfully stopped. I'm no expert at deciphering these logs, so let me know if I'm not looking in the right place.

Thanks for your help!

kiba
07-04-2012, 02:21 AM
heres the original thread, so he doesnt has to answer the same questions, maybe someone can merge them.

http://rog.asus.com/forum/showthread.php?18428-Can-t-get-WLAN-to-stay-enabled-on-new-G74SX

I still think that a fresh install of windows without ANY bloatware might be a big help of resolving whatever issue you might be having. but listen to dstrakele, he knows his stuff w/ these laptops, hes helped me out many times.

and sorry, before i assumed that you were talking about a G75 because of the forum.

jbunnelle
07-04-2012, 03:28 AM
So I restarted and right away it found all surrounding networks, which has happened erratically before. I selected mine, entered the password. The screen came up where you define it as Home, Work, or Public. I selected Home. Next came the screen about access options for home networked machines also running Win7. I just clicked next. Shortly thereafter, the signal bar icon on the lower left lost the signal. I opened it and saw that my network was now gone from the list. The other five or six surrounding networks showed for a few seconds longer. Then all vanished and the dreaded red X returned. Went back to my other laptop and all signals were still active. Checked the Asus Wireless 3 app and saw that both WLAN and Bluetooth were deactivated again. I turned them on with the F keys, closed and reopened. They were grayed out again. The fact that I can see these connections sometimes makes me think it's not a hardware problem and that there's some driver conflict. Would that be a (semi-)accurate assumption?

dstrakele
07-04-2012, 04:46 AM
You have one of the older, problematic Atheros drivers installed. Download the 9.2.1.470 version from http://rog.asus.com/forum/showthread.php?5224-Drivers-Apps-and-How-to-s&country=&status= . Then unintall your current Atheros driver from Device Manager, then REBOOT into Safe Mode and run the installer for 9.2.1.470.

If you still have problems maintaining a coonection, choose "Start", then type "manage wireless connections" in the Search box, and press Enter. In the resulting Dialog, look on the right side and choose to "change network order". Find your connection, right-click on it, and choose "Remove". Then click on the Wireless icon in the System Tray, locate your router SSID, and connect to it.

jbunnelle
07-04-2012, 03:44 PM
So I uninstalled the drivers, checking the option to delete all driver files from the system when doing so. I rebooted into safe mode and installed the new ones. I restarted, and still no signal. I enetered the "manage wireless connections command" but the resulting box says that it is searching for devices, make sure it's discoverable etc. I wait but it never finds any networks.

I'm doing a clean install of Windows from the ISO that's linked in the other thread. When it's finished, what's the minimum I need to load up to test, apart from the Ath. drivers above? And what are the Azure-whatever drivers? Do I need that package also? Which WLAN driver should I use?

Thanks again, really appreciate it.

jbunnelle
07-04-2012, 04:34 PM
So I did a clean install from the ISO. Loaded the chipset, then the Atheros WLAN driver you linked above. When it's finished installing, all wireless connections appear. I wait about 30 seconds before I try to click on mine, to see what happens. As before, all vanish and are replaced with the red x denoting no connections. Ugh! Brand new too. Any ideas? Think this might be an RMA case? Thanks.

P.S. A desperate thought from a desperate mind, but would there be any compatibility issues between this laptop and my modem and/or router? Both are working fine (obviously, since I'm typing this).

dstrakele
07-04-2012, 04:53 PM
Rather than RMA, contact your retailer and exchange your defective laptop for a new unit.

jbunnelle
07-05-2012, 04:43 AM
Out of ideas and combinations. I've sent newegg an email with a request to return. Thanks for your help.

jbunnelle
07-14-2012, 03:02 AM
Just an update in case anyone else ever has this issue:

Before I sent the unit back to newegg.com, I ordered the Intel 6230 network card and replaced the stock Atheros card with it. Worked like a charm! I'm good to go. Thanks, all, will stick around this forum now that I've found it.