View Full Version : G55 touchpad lacking some multi-touch capabilities

07-05-2012, 07:47 PM
I've tried contacting support about this issue, but after "reinstall the driver" and "Reset your BIOS to factory default" they decided the only fix was to ship my computer off to their service center which isn't impossible and won't interfere significantly with any of my near-future plans, but still isn't something I want to do for an issue that seems like the driver just isn't the right version. Thus I have come here, to see if this issue is unique to me (and thus something wrong with this specific device) or if this is common but nobody else had decided to make a thread yet.

So the problem is, two-finger and three-finger tapping on the touchpad have no effect. Reflecting this, there are no settings in the touchpad options relating to two-finger or three-finger tapping. In fact, there are no options to customize most multi-touch gestures at all, and my touchpad options menu is extremely different from the touchpad options menu shown in the troubleshooting documentation. For comparison, the troubleshooting guide listed under "Multi-touch gesture" for the G55 is here (http://support.asus.com.cn/Troubleshooting/detail.aspx?SLanguage=en&p=3&m=G55VW&s=397&hashedid=3yWw7QOsOfFxPNjq&os=&no=1776) which includes images intended to assist in configuring the options, while my options menu looks like this (http://puu.sh/G79o), lacking any indication of multi-touch tapping compatibility or customization of the functions for each gesture.

The driver version I currently have installed came directly from the G55 download page, V10.5.9.0 Elantech touchpad driver updated 2012/03/15. I bought my G55 less than 1 week ago and have not removed any included software. If the issue is not common or at least known then the only recourse left before needing to either replace or repair would be to completely remove the touchpad driver before trying to install the new one (which I didn't do last time because I didn't have access to an external mouse at the time).

07-09-2012, 12:34 AM
Mostly just a bump, but I do have some (not much) new information.

I just tried removing the driver before reinstalling it, though I only did so through the Windows uninstall a program interface so it's possible there are still pieces sitting around somewhere. I tried to use Driver Sweeper, but it couldn't even find a touchpad driver. Regardless the problem hasn't even changed with the exception of forgetting the few settings I could change (Specifically related to scrolling).

Right now I'm at a loss since it looks like I'm the only one with this issue, but it seems like the problem must be the software since the pad doesn't have trouble detecting multiple fingers it just doesn't do anything in reaction to one of the possible gestures and doesn't have the full customization options it's supposed to for other gestures. On the other hand, it should be the exact same software as everybody else has so it can't be that. I'll probably try calling customer support instead of just going through the e-mail support (Which didn't tell me anything different than the self-diagnostic tests) but may just have to get a replacement...

07-09-2012, 12:41 AM
The G-Series notebooks have a very lousy touchpad. I have found that my G53SX has the same types of multi-touch problems as well. I do not worry about it, since I happen to use an external mouse. Considering that I have the same level of touchpad experience under LINUX, I believe it to be a combination of hardware and software. There is not much you can do about it, since the touchpad drivers are not particularly buggy. They tend to work or not, but I have not heard reports of touchpad drivers taking down Windows the way that video card drivers do. Good luck!

07-09-2012, 03:47 AM
Not much to do but replace it or ignore it then? It's not a huge issue since, like you said I generally have an external mouse, but on the other hand the time I am most likely to be using the touchpad is when I'm only using the laptop for browsing and that's also the time I would be most effected by the problem since the middle mouse button that two-finger tapping normally emulates is the "Open in new tab" shortcut that I use all the time.

I'll probably just get it replaced since it's not much of a hassle and there isn't anything sensitive or irreplacable on it yet. Thanks for the advice, good to know I'm not the only one so it's more likely a "rare but minor problem" than me breaking it somehow...

07-09-2012, 04:06 AM
I for one think my G55 touchpad is excellent and a huge improvement over my old G73.

07-15-2012, 11:22 PM
Update! Completely exchanging my G55 for a different G55 from the same retailer DID NOTHING, so now I have a machine with the same problems but missing all the stuff I've downloaded. STILL NO CLUE WHAT THE PROBLEM IS.

I'm probably not going to bother exchanging again since it's not that significant, but RAGE.

So I ask anybody else who owns a G55: If you go to
Control Panel -> Hardware and Sound -> Mouse -> ELAN -> Options
Does the menu shown look more like this (http://support.asus.com.cn/Troubleshooting/detail.aspx?SLanguage=en&p=3&m=G55VW&s=397&hashedid=3yWw7QOsOfFxPNjq&os=&no=1776) from the troubleshooting page or this (http://puu.sh/G79o) from the computers I've been given.

08-27-2012, 11:12 PM
same here... no two finger and three finger taps settings.

Also, in my opinion the driver does lousy job detecting "incidental" touches... for short typing it is OK, but always when I rest my hands on my keyboard for "longer" typing, a random mouse movements and clicks happen.

Also, two finger horizontal and vertical scrolling works fine, but no setting for it to work on the panel without setting the focus. You first have to click on the panel, and only then the scrolling gestures start to work.

Aside from those issues, I like the build quality, and especially three finger gestures. (turned off zooming and rotating gestures on other hand, don't seem very useful)

08-28-2012, 12:03 AM
I d/l and unzipped the drivers for the touchpad for g55 (recommended at the time of writing this)...
Within the unzipped folder, there is a x64 folder, and within it, there is a "DellTPad.exe" (whatever that does there I don't know :) )...

Anyway, through this program I redefined the left button on the pad to work as middle click (I usually have done that on past laptops), so touch on the pad = left, left button = middle click, right button = right click... After setting it like this, I tried and restarted, and the setting is kept.

Another thing I will try to play with there is "Touch sensitivity" and "Touch check" settings to see if I can do away with the random cursor movements while I type... That would probably be sufficient for me until the drivers are properly updated... (still will miss the scroll under cursor option)

08-29-2012, 03:52 AM
Having the same issues. The ui in the touchpad settings doesnt match any of the videos or documentation provided by Asus.
Even the user manual that was in the box shows different screens. I know that "screenshots may vary" but features shouldn't.

I have reinstalled the OS and drivers multiple times and all i can come up with is that the drivers are stripped down or for a different model.

I am currently waiting for support to respond to my inquiry.

08-29-2012, 04:30 AM
I'm not sure, but I suspect the ASUS documentation was created pre-release with a more fully-featured Elantech touchpad driver that was found to be "not ready for prime time", so they had to go with a more basic, but more stable touchpad driver version while the bugs in the "yet-to-be released" fully-featured driver are ironed out.

OR ASUS created the documentation for a completely different touchpad driver on a completely different laptop and no one managed to catch it...

At any rate, don't waste time attempting to reinstall the current driver. Contact ASUS (maybe PM MarshallR@ASUS on this forum) and see if he/they have any info on a pending Elantech touchpad driver release.

08-31-2012, 05:27 AM
Bad drivers and old documentation is no excuse when you are paying ~$1500 dollars for a computer, in my opinion.
With that said, if you go into the Windows Registry using regedit and navigate to the key:
and edit "Tap_Three_Finger_ShowItem" setting it from 0 to 1 will enable the 3 finger tap menu.
The setting will appear under "Tapping" on the "One-finger" tab in the Elan Smart-Pad Settings Screen.


There are other Registry keys there that might help enable other missing features.

As a disclaimer... Editing the registry is not typically a recommended practice and i am not liable for anyone messing up there computers.

The article I stumbled upon that helped with this:

08-31-2012, 05:56 AM
nice finding :)

09-02-2012, 09:09 PM
I found a solution to the two finger middle-click!

Similar to what Nicky said, in regedit there is a Tap_Two_Finger_ShowItem value that is set to 0 by default. Change that to 1. This will allow the 2 finger tap gesture to be shown on the touchpad options menu.
Next find Tap2FunStaticText which is set to 1 by default. Change that to 0. This will allow you to change the function of 2 finger tapping, and select from the drop-down menu "middle click".

Link (http://puu.sh/11qAh) to what it should look like in the end since forums don't like puush...

09-03-2012, 06:15 PM
(Background and History of the Problem) - pls skip this part if you're not interested on how I got the same prob.
Hi! This is my first post but I had my G55 for more than a month now. (bought it on July 4 but got it on hand and first used it July 28). I have experimented on it quite a bit before I took the professional licensure exam here in the Philippines so I have forgotten the specific steps I did when I bumped into the same problem as yours. Before anything else, I had the laptop in a perfect condition (no problems except for a trace of adhesives near the top of the screen w/c can be easily removed when I get the time to do it and a small space on the left side near the keyboard w/c seems to be not part of its design). So moving back, I had the problem when I updated drivers etc. etc. from Asus Live Update (and nearly updated the BIOS from 206 to 209 using windows). As I was updating, I went here in the ROG forums and got some tips that ASUS LU is not good for your laptop so I stopped updating using LU Utility. When I tried to run the game "DreadCabal", it won't run as a certain dll is said to be corrupt. So I tried running the game in Windows Safe Mode (but still failed to run the game). When I restarted with the normal Windows, I noticed that the hand gestures on my Keypad were not working but the basic functions of moving and clicking are working fine. So, I tried to restart the pc again but didn't solve the problem.

(My Solution)
What I did was, I uninstalled the driver ETDWare PS/2-X64 (Elan) using windows uninstall utility. I restarted the PC again then inserted the CD that came with it (or you may just use the "e-Driver" under "Asus" folder in the "All Programs") and reinstalled the driver for touchpad. I restarted the PC and it worked fine again - all the hand gestures are working fine.

My current driver version is
Elan Smart Pad enabled
Dynamic Icon displayed
If the said solution won't work, try running all services that you might have accidentally disabled. Or maybe you have installed a program that is corrupting the drivers or which are not compatible with Elan (just maybe).

Hope it helps.