View Full Version : GPU Tweak gives me a black screen when I apply any change

07-06-2012, 04:26 AM
Just like the title I tried 2.06 and 2.0.83 and each will not allow me to change anything on my TOP Radeon 5850. If I even downclock the screen goes black when I hit apply. Running Cat 12.6 right now.

I can o/c like a beast on AMD overdrive but that makes my second monitor flicker. In games, on youtube and playing movies in WMP. The hardware acceleration disabling fixes the flicker oon desktop apps but not in games.

I have read and read and read about this problem and was hoping GPU tweak would be the answer.

08-14-2012, 09:07 PM
when it black screens does it recover? or is a reboot requires? because it black screens for a second or two for me aswell but then its fine

08-30-2012, 01:58 AM
It will just sit, as for the newest version 2192 that will not even run, just gives me that "Close the Program" prompt. I am going to try the new 2201

08-30-2012, 02:08 AM
That's a no go on 2201 as well.

09-01-2012, 12:11 PM
What graphic cards are you trying to overclock, and do you have Auto updates enabled in OS?

09-01-2012, 08:07 PM
What graphic cards are you trying to overclock, and do you have Auto updates enabled in OS?
Automatic Updates are enabled. This is an ASUS TOP version EAH5850. Running latest Cats 12.8 (Also happens on 12.1, 12.3 and 12.6).

The program will not run, and the older versions just freeze my system with a blank screen. I run a dual monitor system if that helps.

09-02-2012, 03:09 AM
Do you have any 3rd party monitoring software running? Close the other monitoring software and run the program to see if still crash. Cheers.

09-03-2012, 10:57 PM
I only have the Vision Control Center and the AMD Overdrive program installed (stand alone not the one included in VCC)

09-04-2012, 05:18 AM
Please try to remove the AMD Overdrive application and Vision Control Center . And check if everthing is ok. Cheers.

11-15-2019, 07:58 AM
I have the same problem. I've used GPU Tweak 2 before and I quit using it because of multiple problems. I decided to try it again hoping it would improve. I used it all day yesterday. I changed the settings to start with Windows, changed the OSD to show everything except the CPU info, changed the GPU clock, the memory clock and power settings to approximate my settings in AMD Settings. I benchmarked it and saved three profiles. When I ran the benchmark, all of the OSD options that I added were showing zeros, except the FPS and a voltage setting. The options screen went blank, except for check mark boxes. The benchmark itself worked great with the new settings. After I saved the three profiles, I was making some changes and when I hit Apply the screen went blank. I waited for it to recover and it never did. I tried pressing Ctrl+Alt+Delete and nothing happened. I had to turn off my computer and manually restart it. GPU Tweak 2 did not start like it was supposed to. When I opened GPU Tweak 2 again, the adjustments were there, but there was no text. There were no profiles at all. After a minute or so the screen went blank again and never recovered. This is unusable now! What is the problem? I would like to get this working! Please help!

I have GPU Tweak II Version 2072. I have a ASUS Radeon R9 390X DirectX 12 STRIX-R9390X-DC3OC-8GD5-GAMING 8GB 512-Bit GDDR5 PCI Express 3.0 HDCP Ready Video Card. I am on Windows 7 Ultimate. I have been using only AMD Settings to adjust my settings. I did set compatibility mode to Windows 7 and to Run as Administrator on GPU Tweak 2.

Thanks for your help!