View Full Version : nvidia hardware not detected anymore on G53sx

07-10-2012, 04:14 AM
I've got a rog g53sx, and the nvidia gefore GTX 560M is not detected anymore by windows.
It is impossible to install new driver, and official NVIDIA driver does not detect the hardware as well.

The point is that, in the control panel, the device id of the display card is:

I guess that the real id of the graphic card should be:

I also guess that this is why asus e-driver nor nvidia installer does not detect the graphic card, and therefore are not able to
install the driver ...

Any help would be appreciated.

07-10-2012, 10:43 AM
I used to have my card dying on me and not detecting for sometime. I installed an older (ASUS PROVIDED) nvidia driver, I think it was 297. something and it worked fine. BTW REMOVE THAT ASUS E-DOWNLOADER OR AUTO UPDATE thing, it messes up with your drivers. Just go to the Asus support page and download the required drivers from there.


Hope this helps.

07-11-2012, 03:49 AM
Thanks for the update.
Unfortunately, i've experianced this behaviour in the past.
After a reboot, the graphic card is not detected any, and impossible to reintall the driver. However, after a while, the geforce gets detected again and everything runs well as usual.
However, this time the computer cannot recover, and i've tried to dissable/reassemble, reformat, and reload all the drivers, the GPU still gets not detected.

I even tried to add the device id 000010DE (SUBSYS field) into the .inf file of the driver to force a reinstallation, but the only thing i get is a freeze during windows startup ...

07-13-2012, 06:18 AM
Just download the 297 nvidia mobile driver, do a clean install and then restart. Also, try shutting the computer down after installing the driver.
I know what you're going through somewhat because when I just removed my ASUS from the box, this happened to me for the first few days and then it worked flawlessly.

Perhaps one of those 'just out of the box' things.