PDA

View Full Version : RMA question for G74SX



Cylphid
07-12-2012, 11:00 PM
Hi,

I've had an ongoing issue with my G74 artifacting in games and screen corruption while watching videos.

I RMA'd the laptop last month, but the entire time it was in Milpatas, the status showed "Waiting for customer confirmation". So I called and was told by an employee that it was in repair and that the page would be updated. Never happened and the laptop was returned as NTF, no repair.

Well, I still have artifacts, and I still have screen corruption in videos.

My question is this. On the off chance that it actually did not act up when being tested, can I take and print screenshots of the issues and enclose them with the laptop? Would Asus techs regard that as proof?

I'm just hesitant to go through the entire process again, and most likely still getting it back un-repaired.

Thanks in advance.

dstrakele
07-13-2012, 01:43 AM
You can do anything you want. I think it would be very helpful to provide a step-by-step reproduction scenario. However, that doesn't guarantee they'll use it.

From what I've read, they'll do a Factory Restore, then try to reproduce the problem. So you should be sure your repro scenario is successful in that environment.

That said, the NVIDIA driver version plays a big role in video corruption you may experience during games or watching videos. What version are you currently running?

I'd recommend downloading the recent 304.79 BETA version from the NVIDIA web site, booting into Windows Safe Mode and performing a clean install. Choose to "Custom Install" and then check the "Clean Install" checkbox. This will uninstall your current version prior to installation. Booting into Safe Mode will disable other running drivers (such as Antivirus) that may potentially interfere with your NVIDIA driver installation.

Cylphid
07-13-2012, 10:53 AM
Hi dstrakele

Thanks for the reply. I should have noted in the first post that the 304.79s are about the only set I haven't tried lol. This problem has persisted through 3 fresh win7 installs, oh, and temps never exceed 65c. These 2 screenshots took me about 5 minutes to get last night.

http://i.imgur.com/KgqaW.jpg
http://i.imgur.com/7bk2S.jpg

The other item is that they didn't do a factory restore while they had it, which really surprised me.

dstrakele
07-13-2012, 12:28 PM
One thing I've noticed is that once video corruption is reported, it will often persist through installs of various versions, even prior stable versions. I believe this is due to driver remnants that do not uninstall. It sometimes requires using Driver Sweeper from Safe Mode to remove any NVIDIA driver remnants, as well as CCleaner to clean up the registry. But a fresh Windows install should certainly have success.

I'd send those screenshots along with the detailed keystroke-by-keystroke steps used to generate them.

But I would also recommend seeing if you could reproduce them after an ASUS Factory Restore.

One more thing, have you confirmed your outlet is properly grounded? Can you reproduce the artifacts while on battery?

Cylphid
07-13-2012, 01:28 PM
On the grounding, I can certainly check that. It should be ok as I just paid to have my house fully upgraded to 200 amp service, all new outlets etc. I haven't tried it on battery alone yet, but will do tonight.

On the factory restore - it was the original factory image (minus bloatware per the guide at NBR.com) that started the whole driver/hdd/reinstall process, but I do have the factory discs from Asus and another spare hdd I can use.

Driver installs - I have used ccleaner regularly in safe mode after uninstall, but haven't used driver sweeper for a while. I will give that a run tonight, and will use those newest betas you mentioned.

I've also tried uninstalling from the cp and device manager both. If I'm trouble shooting, I usually uninstall, reboot to safe mode, manual search and delete folders, run ccleaner on file system and registry, reboot and custom, clean install, reboot and test.

What gets irritating is that at times it looks perfect. Gears Of War pc is the worst offender, yet last night it would not artifact at all, yet those screens in L4D took all of 2 minutes to get.

By the way, your help is very much appreciated, thank you.

dstrakele
07-13-2012, 02:16 PM
It may also be useful to connect your laptop to an HDTV to see if it also displays the video artifacts.

Cylphid
07-13-2012, 02:20 PM
Ah, didn't even think of that! - will do that tonight too, thanks.

cl-scott
07-13-2012, 04:17 PM
Hello Cylphid,

If you want to PM your RMA # to me, I can take a look at any notes that might have been put in by the technicians. My time spent as a hardware tech gives me a couple of suspicions about why it was sent back NTF, but I would definitely want to check the technician's notes before I say much more than that. Also, any details you can give to help duplicate the issue would be helpful. Ideally you can find some program that is not a game, which causes the problem so that the technicians are able to verify the issue and there's no risk that your game disc gets lost in the shuffle. Maybe a benchmarking program?

Cylphid
07-13-2012, 06:47 PM
PM sent - thank you sir :)

cl-scott
07-13-2012, 11:16 PM
As others may benefit from some of the suggestions I sent Cylphid, I will repost them here.

Having worked in a depot repair center before, let me just give you a couple of tips on how to improve your odds.



Find some way to replicate the issue quickly and reliably.


Odds are every tech in the place has 20-30 units behind yours waiting, so they can't spend a couple of hours or days working on any given unit, even though they may want to.


Do not assume that they have an Internet connection.


I know this one sounds strange, but where I worked (not an Asus facility), they refused to pay for anything other than a very unreliable cellular modem connection that could barely handle basic web browsing, so forget about youtube or anything else. The fewer assumptions you make the better. That is why I suggested a benchmarking program. Even better is if you can find a specific test that will always trigger the issue.


If you can get color printouts of the photos you posted, send those with the unit.


They probably can't go off of those alone, but it may give the tech an idea of what kind of issue they're looking for and how to trigger it.


Problem descriptions are crucial


In the notes it said something about lines across the display; if I saw that description while I was working as a repair tech, I would be looking for signs of an LCD panel failure. What you appear to have is an issue with the GPU, and it's not really lines so much as drawing artifacts.





So spend some time trying to find a way to quickly and reliably trigger the issue. If you can say that running this test on this benchmarking program (conveniently installed on your laptop) will trigger the issue, then it makes the life of the tech a lot easier and you're much more likely to get your unit repaired.

Cylphid
07-31-2012, 09:57 PM
I wanted to bump this thread to thank Scott B. From Asus for his assistance - great communication and some very productive tips.

I took screen shots of issues, printed them up, and also took some FRAPS movies of the graphics issues I was having, enclosed it all with a detailed decription of the problem.

Asus received my laptop last Wednesday the 25th, and shipped it back out Thursday the 26th with a new system board and a new hard drive.

I have a few hours back in game now, several titles, and this G74 has never felt so smooth and sweet. :)

Thanks Scott for all your help! And I hope those tips can help another frustrated user.

Peace out.

chrsplmr
07-31-2012, 10:39 PM
Well....aWelcome breath of fresh air ... that was Mr.Billings eh? Awesome...Now thats a turn around time and testimony.thnx..c.

Cylphid
07-31-2012, 10:51 PM
I have to be honest - I was expecting to have the same experience I did the first time, so Scott jumping in was quite the welcome relief. Could not ask for a better turn around either.

Regarding the laptop - I'm kind of a perfectionist and a little anal about my equipment....this machine came back from the factory in mint, showroom condition. I don't want to carry on too much, but good, solid work by the repair center tech who had this as well.

All around happy camper here, which also sets me at ease about purchasing Asus in the future. I will. :)