View Full Version : U32U AMD E-450 Laptop - SATA 6.0Gbps - SSD performance

07-13-2012, 10:44 AM
anyone has experience with Asus U32U or 1215B which is running on AMD E-450 processor ?

i recently upgraded to Corsair SSD Force 3,

- secure erased the SSD - to reset the performance
- have installed a fresh copy of windows 7 32 bit
- the SSD is 4K aligned
- running in AHCI mode with AMD AHCI drivers installed

- tried both included AHCI drivers and latest from AMD
- tried BIOS 204 and upgraded to 208 as well

the issue that i am having is the performance of the SSD is more like it is hooked up to a SATA II 3.0Gbps interface (slow)

the specs of the U32U (and AMD A50 Fusion controller hub) mentions that it supports SATA III 6.0Gbps (which is supported by the Corsair Force 3 SSD)

i have done various benchmarks with the U32U set to high performance mode and AC adapter hooked up.

any suggestions / ideas on how to get the advertised performance ?

(the same SSD is able to hit the advertised performance when tested with a desktop computer)

azri h.a.r
07-15-2012, 06:54 AM
Hi, did u find the solution yet. I hope u can share if u do because I'm about to buy the same ssd to upgrade my asus u32u too. The reason I want to upgrade because of 1st better power consumption, 2nd better durability, 3rd faster speed(yeah speed wasn't my priority). Did u noticed any of this? Does it require any adapter to make it fit nicely into the hdd bay? Any other additional process to be done so the system can recognize and optimize it? ;)

And of course i'll be searching for the solution too since i'm might facing the same issue

04-04-2015, 09:31 AM
I have the U32U. I recently got a Samsung 850 Evo SSD and replaced the HDD. I am also on BIOS 208, with AHCI enabled. The SSD is running at 3 Gbps when it supports 6 Gbps. If anyone found any solutions to this, that would be great!